Stream is Offline ALWAYS

For the past tow days i tried all kind of installation of single server"rpm based centos6 cento7, de based xenial trusty and jessi", Live streams always off.
Upload>Live stream entry>hls…>ok
Entry LIVE STREAM details:
rtmp:// and the Stream Name 0_dosbbbjw_1
some other installs had this url
rtmp://@PRIMARY_MEDIA_SERVER_HOST@:@PRIMARY_MEDIA_SERVER_PORT@/kLive/?p=100&e=0_dosbbbjw&i=0&t=6e2124eb and the Stream Name 0_dosbbbjw_1

both urls had same result, stream offline.

#2manual live stream entries with 100% working url and in server ffmpeg stream , STREAM OFFLINE too.
sometimes used conf.ans sometimes manually prompted ;
ENVIRONMENT_NAME=“Kaltura Video Platform”

what am i missing here please?

Forgot to mention, during all setups there is no port forwarding neither firewall involved.

Hi @s.u,

Please see my response here:


Hi @jess
Simple. Are you saying if there is not cluster but a single all in one server this options should be empty?
In my case i thought it just should be which i used whenever prompted, because its all in one, right?
In other words i still do not see where am i wrong?

Hi @s.u,

Not sure I understand what you mean by this… Regardless of whether you intend to deploy a cluster or an all in one, the service/endpoint URL MUST be resolvable. See my reply on the other thread you started:

For live streaming, see my post here:

Hi @jess . Bare with me please.
The more i read the more confused i get perhaps i will figure it out ASAP.
did you see my conf.ans ? In my particular case the domain dns setup is done as usual. What should this endpoint url be? In my case tried && both same outcome as mentioned in first post.
Now as for streaming say am using OBS studio to stream . Being said iafter reading kaltura’s online doc for such app i found that should follow this structure.
rtmp://@PRIMARY_MEDIA_SERVER_HOST@:@PRIMARY_MEDIA_SERVER_PORT@/kLive/?p=100&e=0_dosbbbjw&i=0&t=6e2124eb and the Stream Name 0_dosbbbjw_1
Which i did and explained in my first post. Obs would be steaming with green indicator at the bottom and stream under preview and embded is ALWAYS offline.

the path has the stream fragments .ts and m3u8 , but inside kaltura on the review and embed the stream still offline, should be online as there are fragments and obs studio is streaming right?

Hi @jess allow me spamming here ;
just enabled cloud transcoading and tv channels from the admin panel ;
obs studio reports me the following message now while it wast streaming before ;
Could not access the specified channel or stream key, please double-check your stream key. If it is correct, there may be a problem connecting to the server.
the tv platform studio shows the following error;
The requested URL /apps/studioV3/v3.2.1/index.html was not found on this server.
Apache/2.2.15 (CentOS) Server at Port 80
nothing works with me so far i started to feel frustrated . what am i missing now?

I have the same issue.
I used oss to push streaming , oss show me push streaming succeed, but stream offline on kmc.

I also can’t open the liveDashboard. what am i missing now?

The requested URL /apps/liveDashboard/v1.5.4/index.html was not found on this server.


This is OSS config

Hi @darkal, @s.u,

You’re not following the correct flow.
Please read my reply here: is a step by step guide. Make sure you follow it precisely and provide the exact output/description of failure when encountering errors.

Hi @jess
believe me i read and research before posting or replying, i have read all the mentioned links days before. two questions here;
#1what is the use case of live entry, dash hls ,where we will get the rtmp url and stream name?
#2 according to kaltura doc, its possible to directly stream from obs studio to kaltura, which is answers my first question i think.
now streaming the way the link explain with manual entry is usefull if you have a m3u8 file , but what i need is rtmp live stream directly to kaltura, thats why i been trying with live entry dash hls, and then taking the provided info rtmp://@PRIMARY_MEDIA_SERVER_HOST@:@PRIMARY_MEDIA_SERVER_PORT@/kLive/?p=100&e=0_dosbbbjw&i=0&t=6e2124eb and the Stream Name 0_dosbbbjw_1 and put them into obs studio , as mention ed here by kaltura docs,
dose that make a sense ?

Again, you’re following the wrong flow is only relevant if you’re working against our SaaS ENV [i.e]. It will NOT work with self hosted CE ENVs.

You need to follow, instead.

See also: Live streaming working great

Hi @jess
Thank you, is there a list or comparison of available features between kaltura ce and commercial ?
what code snippets need to be added so we could have adaptive bit rate with manual streaming?

Hi @s.u,

As noted in the documentation, this solution makes use of the Nginx RTMP module.
You can achieve adaptive bitrate functionality by making use of FFmpeg which the Kaltura platform relies heavily upon and is therefore included in our repos and deployed when installing Kaltura CE [package name is kaltura-ffmpeg].

This post includes sample configuration with which you can accomplish this. You can skip the “Setup Nginx and RTMP module” section altogether as all the needed prerequisites are already provided by the kaltura-nginx package and go right to the “Configuring nginx for live streaming” section.

When using the deb package, the config file to edit is /opt/kaltura/nginx/conf/nginx.conf, for RPM, it’s /etc/nginx/nginx.conf.

Hi @jess @s.u ,
Follow the steps with,
I successfully pushed the stream with OSS and KMC entry video is live.

OSS config is :
URL : rtmp://your.domain:1935/kLive/
Stream key: darkal

KMC config is:
Live Mobile HLS stream URL:

It’s also available with ffmpeg:
ffmpeg -re -i /Users/xxx/Documents/12345.mp4 -c copy -f flv “rtmp://your.domain:1935/kLive/darkal”