Kaltura 13.6 - Service kaltura-batch doesn´t work


#1

In Centos 6.9 when I start service kaltura-batch it work only few seconds and it stop because I see in log that:

PHP Fatal error: Undefined class constant ‘COPY_CAPTIONS’ in /opt/kaltura/app/plugins/content/caption/base/batch/CopyCaptions/KAsyncCopyCaptions.class.php on line 35

And service monit sends many emails because service not work (monit alert – Does not exist batch)


#2

Hello @angober,

Looks as though the batch client regeneration did not happen during the post upgrade configuration phase or else, it was attempted and failed. Your other recent post supports this theory as well. At any rate, i suggest you remove
/opt/kaltura/app/base-config*lock and re-run the configure scripts. If this is a dedicated batch node [as opposed to an all in one] you should rerun:
kaltura-base-config.sh and kaltura-batch-config.sh, otherwise, for an all in one server, simply run kaltura-config-all.sh.

If after doing so, it still does not work, please run the commands from my post here one by one and report any failures you may see:


#3

I ran your commands and I worked fine.
Thanks a lot.


#4

Most welcome, glad to hear we’re good:)