Push videos to Youtube via Kaltura distribution module

I tried to configure the distribution module in Kaltura admin console for youtubeAPI.
What should I do to connect Kaltura with youtube API?
I configured the distribution module for a special Youtube account ID and I also create two special categories ‘YoutubeCategory’ and ‘YoutubeKeywords’, but it doesn’t work - distribution process failed.

Hello @Emily,

In order to troubleshoot this, go to Admin Console->Batch Process Control->Entry investigation and input the entry ID you’ve tried to distribute.
Under Entry Processing History, you will find a job called Distribution Submit. If you can’t deduce the problem from error message you’ll see there, please post it here and I’ll guide you further.

Hi community,

in this case, we get the error:

|Distribution Submit (5266)|Failed|32|||Error: Could not json decode the token|Engine found [YoutubeApiDistributionEngine]

Error: Could not json decode the token Sep 13, 2019 11:36:11 UTC 0 Sep 13, 2019 11:36:27 UTC Sep 13, 2019 11:36:27 UTC

Hello @esnecca,

Are you using Kaltura’s SaaS ENV or a self hosted one? If the latter, is it the community edition or the OnPrem one?

Hi Jess,

it is a self hosted community edition (14.16.0).

Hi @esnecca,

In that case, you will first need to create a Google app and enable the following YouTube scopes:

scopes[] = https://www.googleapis.com/auth/youtube
scopes[] = https://www.googleapis.com/auth/youtubepartner
scopes[] = https://www.googleapis.com/auth/youtube.upload

Once you will have done that, you need to edit /opt/kaltura/app/configurations/google_auth.ini, so that it contains the following directives:

clientId = “”
clientSecret = “”
scopes[] = https://www.googleapis.com/auth/youtube
scopes[] = https://www.googleapis.com/auth/youtube.force-ssl
scopes[] = https://www.googleapis.com/auth/youtubepartner
scopes[] = https://www.googleapis.com/auth/youtube.upload

Then reload Apache and go to Admin Console->Publishers->Your partner->Profiles->distribution profiles->your Youtube profile and under Authorize API Access click on Re-authenticate. Navigate to the link and input your Kaltura credentials, then click on Proceed to Google for authorization and authenticate with Google.


1 Like

thanks a lot. we will try this and report.

Hi Jess,

the google authorization process runs fine. We see all access rights and we can confirm these.

But at the end of the process, google redirects to our server:


(X are replacements)

This results in an error:

Invalid parameter(s)
symphony php framework
page not found

In the logs we see:

File does not exist: /usr/share/pear/data/symfony

What is wrong here?

OK, solved the problem. The last problem was a wrong frontend configuration. Thanks a lot @jess, for your help

You’re welcome, @esnecca.

1 Like