Kaltura red5 server is not starting

I am using Ubuntu 14.04 and I am trying to set up Kaltura, by using the instructions below.

I am struck at the step “Configure Red5 server”, it seems I have installed Red5 server but failed to start server, so I am not able to load “hostname:5080”(browser shows screen with title “Unable to connect”) and finish my installation process.

When I check status of Red server it displayed the information below.

sudo service red5-server status

 * Checking status of Flash streaming server red5-server                                                                          [fail]

When I tried command ps fax | grep red5 then it display result below.

3806 pts/13   S+     0:00          |       \_ grep --color=auto red5

Kindly share your idea about troubleshooting this issue

Kindly note, it will load login page while we try to access “hostname/kmc”, browser will ask for login and it will redirect to “hostname/index.php/kmc/kmc2”(after successful login), then browser shows message “Unable to connect”.

Thanks you


As far as KMC is concerned, the way to debug it would be to run:
# kaltlog
as the server’s shell and look at the errors outputted to STDOUT while, in parallel, launching your browser’s devtools and looking at errors both in the “Network” and “Console” tabs.

As for Red5, the package comes from the distro’s official repo and so, bug reports should be sent to
# aptitude show red5-server |grep Maintainer:

A good first step towards debugging it though, would be to edit /var/lib/dpkg/info/red5-serve.postinst and change the first line to read:
#!/bin/sh -x

and then run:
# dpkg-reconfigure red5-server
and look at the output.

Note that red5 is only needed if you intend to do webcam recording from the KMC.

Thank you for your quick response.

Regarding ‘kaltlog’
I am not sure how can I see the log details I tried the command like below

sudo kaltlog
sudo: kaltlog: command not found

Regarding Red5 error
I will send error details to maintainer

Regarding Debugging step
I have edited the file “/var/lib/dpkg/info/red5-serve.postinst” and run the test, then I got the output like below.

sudo dpkg-reconfigure red5-server
 * Stopping Flash streaming server 

red5-server                                                     [ OK ] 
+ set -e
+ DAEMON=/usr/share/red5/red5.sh
+ id _red5
+ chown -R _red5:nogroup /var/log/red5 /var/cache/red5
+ chown -R _red5:adm /etc/red5
+ chown _red5:adm /var/log/red5 /var/cache/red5
+ chmod -R 770 /etc/red5
+ chmod 750 /var/log/red5 /etc/red5
+ chmod 700 /var/cache/red5
+ [ -x /etc/init.d/red5-server ]
+ [ ! -e /etc/init/red5-server.conf ]
+ update-rc.d red5-server defaults
+ invoke-rc.d red5-server start
 * Starting Flash streaming server  red5-server                                                    [fail] 
invoke-rc.d: initscript red5-server, action "start" failed.
+ exit 1

Currently I am trying to make KMC working, I am not sure why I am getting blank page after signing in. I am listing the KMC issue in step by step

  1. When we try to load KMC by http://hostname/kmc, it will display a login screen, there is no network error shown in inspect element.

  2. I logged in as default root user, then it is redirecting to https, so the URL would be https://dipu-virtualbox/index.php/kmc/kmc2

  3. I changed it to http(manually), then we can see browser redirecting to URL http://dipu-virtualbox/index.php/kmc/kmc1(with some query string)

  4. In the new page we could see menu “Dashboard”, “Content”, etc…
    but the main content area remain blank. Also it shows a JS error in console ‘Uncaught SyntaxError: Unexpected token <’

  5. If you click any of those menu(“Dashboard”, “Content”) then it will throw a JS error “Uncaught ReferenceError: loadModule is not defined”

  6. If you click on Logout, then it will throw another JS error “Uncaught ReferenceError: logout is not defined”

I am listing screen shots below.


You should not login to KMC with the admin console user, instead, go to admin console and create a new partner and use it to login.
As for HTTP vs. HTTPs, please see:

As for Red5, please report it to the package maintainers.



Thank you for your help, now I can able to access KMC (by selecting ‘Manage’ option in the table where we can see all publishers). I am listing my current issues below, kindly share your idea about it and kindly share how to debug the Kaltura installation.

I am attaching screenshot as well


If user try to login to KMC using email and password, then KMC shows top menu and blank screen on content area

Do you mean when logging in with the admin console creds? if so, this is not a bug, it is as designed. Apart from the fact that a message should be given to the user indicating that this shouldn’t be done, which we are aware of:)

Throwing the error “
GET http://dipu-virtualbox/html5/html5lib/v2.35/mwEmbedLoader.php 404 (Not Found) in console” while accessing Studion in KMC

Please look at /opt/kaltura/apps/studio/v2.0.1/studio.ini and make sure the URL is correct and your player version is indeed what you see in
HTML5_DIR=`ls -ld $BASE_DIR/web/html5/html5lib/v* 2>/dev/null|awk -F " " ‘{print $NF}’ |tail -1`
HTML5_VER=`basename $HTML5_DIR`
echo $HTML_VER

If changes are needed, please make them and then run:
# php $BASE_DIR/app/deployment/uiconf/deploy_v2.php --user=www-data --ini=$BASE_DIR/apps/studio/$HTML5_STUDIO_VER/studio.ini >> /dev/null

Showing 404 while accessing “Live Real Time Dashboard” option under “Analytic”. Also throwing GET http://dipu-virtualbox/apps/liveanalytics/v2.5/index.html 404 (Not Found) in console

This is a known issue, at the moment, Live analytics cannot be seen in KMC. However, Live analytics are only relevant if you use Kaltura’s Live streaming anyhow.


Regarding Studio Error

Throwing the error " GET http://dipu-virtualbox/html5/html5lib/v2.35/mwEmbedLoader.php 404 (Not Found) in console" while accessing Studion in KMC

I have done the following things, checked /opt/kaltura/apps/studio/v2.0.1/studio.ini

  • There I have seen only one URL "html5lib":"http://www.kaltura.com/html5/html5lib/v2.35/mwEmbedLoader.php"

Then I have done the following thing

dipu@dipu-VirtualBox:/opt/kaltura$ BASE_DIR=pwd

dipu@dipu-VirtualBox:/opt/kaltura$ echo $BASE_DIR

dipu@dipu-VirtualBox:/opt/kaltura$ HTML5_DIR=ls -ld $BASE_DIR/web/html5/html5lib/v* 2>/dev/null|awk -F " " '{print $NF}' |tail -1

dipu@dipu-VirtualBox:/opt/kaltura$ HTML5_VER=basename $HTML5_DIR
dipu@dipu-VirtualBox:/opt/kaltura$ echo $HTML5_VER

dipu@dipu-VirtualBox:/opt/kaltura$ sudo php $BASE_DIR/app/deployment/uiconf/deploy_v2.php --user=www-data --ini=$BASE_DIR/apps/studio/$HTML5_STUDIO_VER/studio.ini >> /dev/null

PHP Fatal error: Uncaught exception ‘Zend_Config_Exception’ with message ‘parse_ini_file(/opt/kaltura/apps/studio//studio.ini): failed to open stream: No such file or directory’ in /opt/kaltura/app/vendor/ZendFramework/library/Zend/Config/Ini.php:184

Stack trace:
0 /opt/kaltura/app/vendor/ZendFramework/library/Zend/Config/Ini.php(125): Zend_Config_Ini->_loadIniFile(’/opt/kaltura/ap…’)
1 /opt/kaltura/app/deployment/uiconf/deploy_v2.php(302): Zend_Config_Ini->__construct(’/opt/kaltura/ap…’)
2 /opt/kaltura/app/deployment/uiconf/deploy_v2.php(33): uiConfDeployment::init(’/opt/kaltura/ap…’)
3 {main}
thrown in /opt/kaltura/app/vendor/ZendFramework/library/Zend/Config/Ini.php on line 184

Also console showing same error again, kindly share your suggestions.

You’re missing the value for this var… it can be taken with:
HTML5_STUDIO_DIR=`ls -ld $BASE_DIR/apps/studio/v* 2>/dev/null|awk -F " " ‘{print $NF}’ |tail -1`


Thank you, now I can able to see Studio option, but it keep on asking access details. Do the user login again to user Studio(please note I logged in KMC selecting ‘Manage’ option in the table where we can see all publishers)

I am attaching the screen shot with this message.


If you open your browser’s dev tools and go to the ‘console’ tab, you should probably be able to see an error, also check the ‘Network’ tab…

No login dialog should show up, looking there will help us understand what the issue is.


I have checked console I got messages below from console first one is warning and second one is just for login purpose I think

angular.js:6 The specified value “!” does not conform to the required format. The format is “#rrggbb” where rr, gg, bb are two-digit hexadecimal numbers.

kWidget: Kaltura HTML5 Version: 2.35

I didn’t see anything error in Network tab, though I noticed below things

Also I have noticed one more thing, when you click on “Studio”, then you get form which ask user to login. If the user click on “Support”(right top menu), then you will get list of players.


If Red5 is need and there is an issue installing Red5 using the Kaltura RPMs is it viable to install it from sourse or using scripts from the Red5 site. I ask only because I was not sure if the version installed by Kaltura is modified or custom to work with Kaltura. My ISP can install a functionally version from source and I have done so myself in the past. After installation I would simply run the configuration script.



Red5 is only needed in the event you want to do web cam recording from KMC.
There is no custom code in the kaltura-red5 RPM, regardless, what exactly is the issue with installing it?

I am able to install Red5 using yum without errors but the process is not running nor can I access the Red5 server using the assigned ports on the specific CentOS v6.6 machine. My other system I was not able to install Red5 at all and that system was running on Ubuntu 15.x. To date the only enviroment I have been able to install Red5 on with no issue is CentOS 6.7.

I did get errors when installing on Ubuntu and that is noted in another thread but based on the information provided I can likely get that working by doing a manual installation from source as noted in many Red5 forums. It appears this is a known issue with Ubuntu repository files that has not been fixed.

So I got Red5 installed using yum on CentOS but dies after starting up.

# service red5 restart
Shutting down red5:                                        [FAILED]
Starting red5:                                             [  OK  ]
# service red5 status
red5 dead but pid file exists

I cannot seem to keep it running now. I checked /var/log/messages but saw no errors. Any suggestions on host to fix this issue?

I tried deleting the pid but that didnt do anything the process still dies with the same message.