Kaltura CE email not sending

I am newbie to kaltura. I have installed it in ec2 ubuntu instance. I can login to admin. But when I try to add a user to it I cannot get password via email. I have installed postfix.
my postfix is sending mail via command line as expected.
Would you please help?

I reinstalled the whole system with centos. It’s ok now.


I am having this same issue. No, emails are being sent by the EC2 Ubuntu instance. Any suggestion on how to fix this issue. I made sure all the ports were open but I recall it being mention that the standard port 25 is disable by default. I did get the email saying that the account was created but did not get the setup password link.


Not quite sure I understand… when a new account is created, the email that is sent should include a reset passwd link.
What sort of account did you create?
Also, if you run:
# mail -s Test you@you.com < /etc/issue

are you getting it? just want to make sure emails are in fact sent in general. If you are not getting it, you should look at /var/log/maillog to understand why. This is of course after making sure an MTA is actually listening on port 25.
Don’t know if you chose to use Postfix, Sendmail, Exim or something else but they should all work fine.

When doing:
# netstat -plnt |grep 25
You should see something like:
tcp 0 0* LISTEN 2190/master
tcp6 0 0 :::25 :::* LISTEN 2190/master

in my case, postfix is used so the process is called master.


This instance does not have a log file for mail in the mail directory at all. So I am not sure if I missed a step in the setup or the script didnt setup one. Next, when I send the test email to a free email account like something@gmail.com it is sent without an issue. However, when I sent a message to a TLD like something@yourdomainl.com it does not process in this is processed slower but it does eventually arrive. So send mail appears to work fine.

As for the netstat results, here is what I got back when running that caption command.

tcp 0 0* LISTEN 16725/searchd

I am not clear if this was the expected results. Finally, to clarify the issue I am having. When I create and additional administrator account in admin console. I get an email saying that the account was created. However, the password reset email to setup the new account is never received. Even after using the reset password link no mail is received to complete configuration of that specific user.

From your netstat output, it does not seem like you have an MTA listening on port 25 at all, so, how exactly are you sending the email?


I will have to check into this and make sure that AWS has Whitelisted the Elastic IP.


I will get back to you on the progress after I complete the changes mention in the caption article.

Hello Everyone,

This issue was indeed related to setting that needed to be updated by AWS to allow my Elastic IP associated with the instance running to use port 25 to send emails. Once this was done the system sent emails without and issue.


I am have problems with email on the system I complete a fresh install on and it is only sending out the email saying that the Kaltura account has been setup but not the email for the user to setup their password for the new account.

the results of the following command are as followes:

netstat -plnt |grep 25
tcp 0 0* LISTEN 29928/master

I have checked my other system having the same issue and found this as the output for the same command. This system is not sending mail at all.

# netstat -plnt |grep 25
tcp        0      0      *                   LISTEN      3440/master
tcp        0      0      *                   LISTEN      25258/searchd

The both systems can send mail without an issue from command line and using a php script but Kaltura is not relaiably sending mail from either system. Any insight you might have to resolve these issues would be helpful.



Not sure I understand. Are you saying that a script like:

<?php mail ( 'your@mail.com' , 'subject' , 'message'); ?>

Works and you are not getting emails from Kaltura? do you see a sending attempt in /var/log/maillog? if not, did you look at /opt/kaltura/log/kaltura_api_v3.log to see if an attempt to send an email was made?

Both of the follwoing instances work sending mail on all systems I have installed.

Now, on one system I see in the ‘/var/log/maillog’ logs that it is trying to send mail from my main host using my top level domain but is getting a user does not exist error. Is there a way to set Kaltura to us STMP authentication for specific user to send mail? If so how to I set this up?

Now, the other system I am positive that is a rDNS, PTR and DomainKey configuration issue because that host nor the DNS used to point the QDN to the system was setup nor managed by me. The logs show error 550 rejections and errors.


Kaltura uses the PHP mail() function to send its emails. If mail() from the PHP snippet works, there is no reason why it will not work in Kaltura’s context.

The PHP mail function, on Unices, uses the MTA running on the machine. That MTA can be postfix, sendmail, exim or any other compatible MTA, PHP simply does not care.

Each of these has a different configuration naturally, if you are using Postfix, it will look something like this in /etc/postfix/main.cf:

smtp_sasl_auth_enable = yes
smtp_use_tls = yes
smtp_sasl_password_maps = 
smtpd_use_tls = yes
smtp_sasl_security_options = noanonymous
smtp_tls_security_level = may
smtp_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
relayhost = 

Note that some emailing services, such as Amazon SES, require that emails are sent from a specific addr.
The address Kaltura uses to send can be configured in /opt/kaltura/app/configurations/local.ini
# grep email /opt/kaltura/app/configurations/local.ini

default_email = customer_service@jessex
default_email_name = Kaltura Video Platform Automated Response
partner_registration_confirmation_email = registration_confirmation@jessex
partner_notification_email = customer_service@jessex
partner_change_email_email = customer_service@jessex
partner_change_email_name = Kaltura Video Platform Automated Response
purchase_package_email = customer_service@jessex
batch_download_video_sender_email = download_video@jessex
batch_flatten_video_sender_email = download_video@jessex
batch_notification_sender_email = notifications@jessex  
batch_alert_email = alert@jessex  
bulk_notification_sender_email = notifications@jessex  
live_report_sender_email = live_report@jessex
report_admin_email = @REPORT_ADMIN_EMAIL@

Need to set all these directives to the address you want and reload Apache.

In addition, it is recommended, in the event your SMTP demands that the emails be from a specific sender, to add:
sendmail_path = "sendmail -t -i -F you@example.com -f you@example.com"
to one of your PHP INI files, can be the main one, i.e php.ini or any other that your PHP scans, so that, if no specific FROM header is set, it will also set it to you@example.com

Post setting that, you will need to reload Apache.

Each such MTA has its own documentation about how to configure it to relay to an external SMTP and you should have no difficulties finding it by a quick Google search.


I did a few things to fix my issue on all my systems as they related to emails. I first updated the DNS records to add PTR information for all my sub-domains. Then I modified the configuration file as described to use my real emails for sending messages. Also update the php.ini file as described. Now, I also implemented domain keys for my TLD and though must of this was not likely required it fix the issue and ensures my messages reach the users inbox rather than SPAM or rejected.

Thank you for help resolving this issue.