Installation fails Bundle-builder-api

I’m getting this on Ubuntu 20.04. I’ve already installed nodes 10.19 before running the script from GitHub

I have tried installing forever
npm install forever -g
indent preformatted text by 4 spaces
Setting up kaltura-playkit-bundler (1.2.0-1+b2) …
npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgrade to chokidar 3 with 15x less dependencies.
npm WARN deprecated fsevents@1.2.13: fsevents 1 will break on node v14+ and could be using insecure binaries. Upgrade to fsevents 2.
npm WARN deprecated urix@0.1.0: Please see
npm WARN deprecated resolve-url@0.2.1:

yarn@1.22.10 preinstall /usr/local/lib/node_modules/yarn
:; (node ./preinstall.js > /dev/null 2>&1 || true)

Job for kaltura-playkit-bundler.service failed because the control process exited with error code.
See “systemctl status kaltura-playkit-bundler.service” and “journalctl -xe” for details.
invoke-rc.d: initscript kaltura-playkit-bundler, action “restart” failed.
● kaltura-playkit-bundler.service - LSB: Start/stop Kaltura Bundle-builder-api.
Loaded: loaded (/etc/init.d/kaltura-playkit-bundler; generated)
Active: failed (Result: exit-code) since Sat 2020-12-12 20:26:27 UTC; 8ms ago
Docs: man:systemd-sysv-generator(8)
Process: 1653 ExecStart=/etc/init.d/kaltura-playkit-bundler start (code=exited, status=2)

Dec 12 20:26:27 ip-172-31-39-5 systemd[1]: Starting LSB: Start/stop Kaltura Bundle-builder-api…
Dec 12 20:26:27 ip-172-31-39-5 kaltura-playkit-bundler[1653]: Need to install the forever npm module. Exiting.
Dec 12 20:26:27 ip-172-31-39-5 systemd[1]: kaltura-playkit-bundler.service: Control process exited, code=exited, status=2/INVALIDARGUMENT
Dec 12 20:26:27 ip-172-31-39-5 systemd[1]: kaltura-playkit-bundler.service: Failed with result ‘exit-code’.
Dec 12 20:26:27 ip-172-31-39-5 systemd[1]: Failed to start LSB: Start/stop Kaltura Bundle-builder-api…
dpkg: error processing package kaltura-playkit-bundler (–configure):
installed kaltura-playkit-bundler package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of kaltura-front:
kaltura-front depends on kaltura-playkit-bundler; however:
Package kaltura-playkit-bundler is not configured yet.

dpkg: error processing package kaltura-front (–configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hi, i have the same issue. Have you found a solution?

Thanks on regards

I noticed even after issuing the command npm install forever -g, the forever command would not run. Ended up just re-install node.js and forever which worked, followed the steps here.

Of course, now I get a kaltura-db error