Widevine DRM Kaltura player

We have Kaltura 16.5 CE running on an RPM cluster. We have configured nginx and kaltura to use a Widevine DRM provider. We are able to play DRM protected videos from VideoJS and Shakaplayer but not with the Kaltura native player. There is no option to configure the DRM license server proxy URL.

I can see in the doc that there is a UI var called Kaltura.LicenseServerURL used for Playready DRM but nothing for Widevine.

Is there anyway to use the Kaltura native player to play Widevine DRM protected video?

Thanks !

Hello ,

Have a look at /opt/kaltura/app/configurations. You will find a widevine.ini conf file.



Thanks for the answer. I tried to set the license server URL in the Widevine.ini file but it is not helping.
I do not see any request going to the DRM provider when playback is initiated. Is there any plugin to activate on the player side?


Have you setup the widevine options on the partner configuration ?


If you are referring to the “DRM - Widevine” option in the “Configure” menu of the partner then yes, that was done.


There is algo a plugins.ini.

Do a grep -ir windevine * on /opt/kaltura/app/configurations and find all settings. I don’t know what else could be missing.


here is an output from plugins.ini


I believe these should be uncommented. right?

I think so. Give it a try

I uncommented the features, executed /opt/kaltura/app/deployment/base/scripts/installPlugins.php then rebooted the front server but it is not helping.

Have you enabled DRM on the player’s configuration ?

Studio>choose player>choose gear>Universal DRM

Yes… that was done as well.