V7 player weird error


I tried a new setup on two identical servers and the V7 player is not working on one of them.

I’m getting this weird 404:

I reinstalled and checked everything twice but haven’t been able to find the problem.

Any help will be appreciated :slight_smile:

Thank you,

David Eusse

Hi @david.eusse ,

Is the playkit bundler running? Assuming that it is (if not, need to start it), please check its logs for errors.
Also, what does the UI conf object for ID 23448175 look like (you can check with a direct select from the ui_conf table or by calling uiconf.get())?


Hello @jess,

The playkit is running. I will check the ui_conf table and let you know because the problem is really strange.

An identical setup runs fine.



Hello @jess,

I just found that the entry exists but not the xml…

This is what I get:
| 23448175 | 1 | 102 | 0 | /content/generatedUiConf/23/448/ui_conf_23448175__182.xml | New Player | 560 | 395 | NULL | / | 2021-11-08 17:46:10 | 2021-11-08 17:46:16 | {“versions”:{“kaltura-ovp-player”:"{latest}",“playkit-kava”:"{latest}"},“langs”:[“en”]} | 1 | kalturaPlayerJs,player,ovp | NULL | 2 | | 0 | 2 | 182 | NULL | NULL |

But the file does not exist:
[root@dev01 448]# ls ui_conf_23448175__182.xml
ls: cannot access ui_conf_23448175__182.xml: No such file or directory

Any ideas ?

Thank you very much for your help,


Hi David,

The fact that /opt/kaltura/web/content/generatedUiConf/23/448/ui_conf_23448175__182.xml doesn’t exist, while confusing without a doubt, does not yet indicate there’s a problem. In fact, the file on disk should be called /opt/kaltura/web/content/generatedUiConf/23/448/ui_conf_23448175__182.config.xml and it’s not an XML but a JSON (yes, again, confusing).
# ls -al /opt/kaltura/web/content/generatedUiConf/23/448/ui_conf_23448175*

Next, is the bundler running?

# /etc/init.d/kaltura-playkit-bundler status

If not, what happens when you start it? and what do you see under /opt/kaltura/playkit-js-bundle-builder/log/?

Hi Jess,

The playkit is running:

/etc/init.d/kaltura-playkit-bundler status
Kaltura Bundle builder API Server is running.

And the config file does exist. I thought it was an error:

-rw-r----- 1 apache kaltura 109 Nov 8 16:46 /opt/kaltura/web/content/generatedUiConf/23/448/ui_conf_23448175__182.config.xml

I haven’t been able to find the cause, any ideas ?


I think I found the problem.

I’m getting this error on kaltura_bundle_builder.log:
err: Error: Command failed: gulp build --silent --gulpfile /opt/kaltura/playkit-js-bundle-builder/lib/…/gulpfile.js --name 2_a9799488597230a862748da5e63da602 --config “eydrYWx0dXJhLW92cC1wbGF5ZXInOicxLjIuMScsJ3BsYXlraXQta2F2YSc6JzEuMS4xJ30=” --dest undefined --source L29wdC9rYWx0dXJhL2h0bWw1L2h0bWw1bGliL3BsYXlraXRTb3VyY2Vz
/bin/sh: gulp: command not found

Should I mess with npm ? I’m running Centos 7.9.

Hi David,

Try rerunning the kaltura-playkit-bundler %post hook (rpm -q kaltura-playkit-bundler --scripts to see it).
Run each command manually and make sure all succeed.

Hello Jess,

I tried npm install -g gulp; yum reinstall kaltura-playkit-bundle and it worked…

I really don’t know what happened.

I appreciate your kind help.



Hi David,

Glad we’re good now.