Tried to install Kaltura KMCng, but failed


#1

Hello Community,

Is there anyone who tried to get Kaltura-NG to run?

I did the installation steps described here:

The following steps went through without error:

# clone our repo
git clone https://github.com/kaltura/kmc-ng.git

# change directory to your app
cd kmc-ng

# checkout latest standalone code
npm run standalone

# sync dependencies to the new branch
npm install

After trying to run the application, it fails (webpack failed to compile)

# run the application in the browser (port 4200)
npm run start -- -o

Output is:

kmc-ng@4.2.0 start /root/kmc-ng
ng serve --preserve-symlinks "-o"

** NG Live Development Server is listening on localhost:4200, open your browser on http://localhost:4200/ **
 10% building modules 3/4 modules 1 active ...rver/client/index.js?http://0.0.0.0:0(node:4134) UnhandledPromiseRejectionWarning: Error: Exited with code 3
    at ChildProcess.cp.once.code (/root/kmc-ng/node_modules/opn/index.js:82:13)
    at Object.onceWrapper (events.js:317:30)
    at emitTwo (events.js:126:13)
    at ChildProcess.emit (events.js:214:7)
    at maybeClose (internal/child_process.js:925:16)
    at Socket.stream.socket.on (internal/child_process.js:346:11)
    at emitOne (events.js:116:13)
    at Socket.emit (events.js:211:7)
    at Pipe._handle.close [as _onclose] (net.js:567:12)
(node:4134) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:4134) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.                                                                                                                  Date: 2018-04-30T10:39:38.283Z                                                     Hash: fe7c76f6ae15b9b58148
Time: 56742ms
chunk {administration-roles-app.module} administration-roles-app.module.chunk.js () 301 kB  [rendered]
chunk {administration-users-app.module} administration-users-app.module.chunk.js () 254 kB  [rendered]
chunk {analytics-kava-app.module} analytics-kava-app.module.chunk.js () 15.4 kB  [rendered]
chunk {analytics-live-app.module} analytics-live-app.module.chunk.js () 18.1 kB  [rendered]
chunk {common} common.chunk.js (common) 333 kB  [rendered]
chunk {content-bulk-log-app.module} content-bulk-log-app.module.chunk.js () 289 kB  [rendered]
chunk {content-categories-app.module} content-categories-app.module.chunk.js () 1.87 MB  [rendered]
chunk {content-drop-folders-app.module} content-drop-folders-app.module.chunk.js () 315 kB  [rendered]
chunk {content-entries-app.module} content-entries-app.module.chunk.js () 3.11 MB  [rendered]
chunk {content-moderation-app.module} content-moderation-app.module.chunk.js () 211 kB  [rendered]
chunk {content-playlists-app.module} content-playlists-app.module.chunk.js () 943 kB  [rendered]
chunk {content-syndication-app.module} content-syndication-app.module.chunk.js () 600 kB  [rendered]
chunk {content-upload-control-app.module} content-upload-control-app.module.chunk.js () 109 kB  [rendered]
chunk {inline} inline.bundle.js (inline) 5.79 kB [entry] [rendered]
chunk {main} main.bundle.js (main) 2.96 MB [initial] [rendered]
chunk {polyfills} polyfills.bundle.js (polyfills) 1.62 MB [initial] [rendered]
chunk {scripts} scripts.bundle.js (scripts) 18.8 kB [initial] [rendered]
chunk {settings-access-control-app.module} settings-access-control-app.module.chunk.js () 375 kB  [rendered]
chunk {settings-account-information-app.module} settings-account-information-app.module.chunk.js () 88.4 kB  [rendered]
chunk {settings-account-settings-app.module} settings-account-settings-app.module.chunk.js () 85.5 kB  [rendered]
chunk {settings-custom-data-app.module} settings-custom-data-app.module.chunk.js () 394 kB  [rendered]
chunk {settings-integration-settings-app.module} settings-integration-settings-app.module.chunk.js () 213 kB  [rendered]
chunk {settings-my-user-settings-app.module} settings-my-user-settings-app.module.chunk.js () 149 kB  [rendered]
chunk {settings-transcoding-settings-app.module} settings-transcoding-settings-app.module.chunk.js () 753 kB  [rendered]
chunk {studio-app.module} studio-app.module.chunk.js () 27 kB  [rendered]
chunk {styles} styles.bundle.js (styles) 540 kB [initial] [rendered]
chunk {usage-dashboard-app.module} usage-dashboard-app.module.chunk.js () 18.2 kB  [rendered]
chunk {vendor} vendor.bundle.js (vendor) 23.7 MB [initial] [rendered]

WARNING in ./src/kmc-app/components/app-menu/app-menu.component.scss
(Emitted value instead of an instance of Error) postcss-url: /root/kmc-ng/src/kmc-app/styles/scss/_kmc-logo.scss:9:4: Can't read file '/root/kmc-ng/src/kmc-app/styles/assets/beta.svg', ignoring

WARNING in ./src/kmc-app/components/login/login.component.scss
(Emitted value instead of an instance of Error) postcss-url: /root/kmc-ng/src/kmc-app/styles/scss/_kmc-logo.scss:9:4: Can't read file '/root/kmc-ng/src/kmc-app/styles/assets/beta.svg', ignoring

ERROR in ./src/kmc-app/components/app-menu/app-menu.component.scss
(Emitted value instead of an instance of Error) CssSyntaxError: /root/kmc-ng/src/kmc-app/styles/scss/_kmc-logo.scss:9:16: Can't resolve '../../styles/assets/beta.svg' in '/root/kmc-ng/src/kmc-app/components/app-menu'

   7 | }
   8 | .k-beta-logo {
 9 |     background: url('../../styles/assets/beta.svg') no-repeat left center;
     |                ^
  10 |     display:inline-block;
  11 | }

ERROR in ./src/kmc-app/components/login/login.component.scss
(Emitted value instead of an instance of Error) CssSyntaxError: /root/kmc-ng/src/kmc-app/styles/scss/_kmc-logo.scss:9:16: Can't resolve '../../styles/assets/beta.svg' in '/root/kmc-ng/src/kmc-app/components/login'

   7 | }
   8 | .k-beta-logo {
 9 |     background: url('../../styles/assets/beta.svg') no-repeat left center;
     |                ^
  10 |     display:inline-block;
  11 | }


webpack: Failed to compile.

Any idea why the webpack fails to compile?

Thanks in advance
Daniel


#2

Hi daniel_mueller_19d,
Sorry for not responding sooner. Can you provide information about the environment you are working with like which OS you are working and also the node version you are working with?

Thanks,
Eran.


#3

@Sakal

I was few days away, thanks for reply to this thread. :slight_smile:

OS Version:

[root@agsstr01 ~]# lsb_release -d
Description: CentOS release 6.9 (Final)
[root@agsstr01 ~]#

Node version:

[root@agsstr01 ~]# node --version
v8.11.1
[root@agsstr01 ~]# npm --version
5.6.0

╭─────────────────────────────────────╮

│ Update available 5.6.0 → 6.0.1
│ Run npm i -g npm to update

╰─────────────────────────────────────╯

[root@agsstr01 ~]#

Should my OS, nodejs and nmp version match?
It seems that there is a update for npm from V. 5.6.0 to 6.0.1
Readme says that npm V 5.0 or abve is needed. I can try to upgrade npm an run the setup again.

Thanks,
Daniel


#4

After Upgrading npm to Version 6.0.1 I got a npm install error:

[root@agsstr01 kmc-ng]# npm install
Unhandled rejection Error: invalid config key requested: singletracted to /root/kmc-ng/node_modules/.staging/asap-69f2e658 (698ms)
at pudGet (/usr/lib/node_modules/npm/node_modules/figgy-pudding/index.js:31:11)
at FiggyPudding.get (/usr/lib/node_modules/npm/node_modules/figgy-pudding/index.js:13:12)
at Object.get (/usr/lib/node_modules/npm/node_modules/figgy-pudding/index.js:71:16)
at _parse (/usr/lib/node_modules/npm/node_modules/ssri/index.js:138:12)
at parse (/usr/lib/node_modules/npm/node_modules/ssri/index.js:125:12)
at Object.checkData (/usr/lib/node_modules/npm/node_modules/ssri/index.js:216:9)
at write (/usr/lib/node_modules/npm/node_modules/cacache/lib/content/write.js:34:31)
at putData (/usr/lib/node_modules/npm/node_modules/cacache/put.js:25:10)
at Object.x.put (/usr/lib/node_modules/npm/node_modules/cacache/locales/en.js:28:37)
at readFileAsync.then.data (/usr/lib/node_modules/npm/node_modules/pacote/lib/fetchers/file.js:38:28)
at tryCatcher (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/util.js:16:23)
at Promise._settlePromiseFromHandler (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:512:31)
at Promise._settlePromise (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:569:18)
at Promise._settlePromise0 (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:614:10)
at Promise._settlePromises (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:693:18)
at Promise._fulfill (/usr/lib/node_modules/npm/node_modules/bluebird/js/release/promise.js:638:18)
npm ERR! cb() never called!
npm ERR! This is an error with npm itself. Please report this error at:
npm ERR! https://github.com/npm/npm/issues
npm ERR! A complete log of this run can be found in:
npm ERR! /root/.npm/_logs/2018-05-14T08_03_20_712Z-debug.log
[root@agsstr01 kmc-ng]#

Any suggestions what I can do next?
Thanks,
Daniel


#5

Hi Daniel,
We are not officially supporting the build process on CentOS. Our machines are using either Windows or OSX. Obviously the transpiled code can be hosted everywhere and can be downloaded directly from our github repository. Are you trying to build it on your own because you plan to modify the sources?

I saw the following guide demonstrating how to run Angular CLI on CentOS. Can you please check the following guide provided by Angular Install Node.js, npm, and Angular on CentOS 7.x. It is for CentOS 7.x but I think you should try it on your environment. If you manage to successfully build thin angular app with scss files we will be able to strike out Angular CLI support for your environment.

Please check and let me know how it went.
Thanks,
Eran.