Standalone 16.04 install failing

The installation on 16.04 is currently failing with the following.
Any pointers would be great.

Kind regards,

Successfully dropped kaltura databases and users
CREATE USER kaltura;
CREATE USER etl@’%’;
CREATE DATABASE kaltura_sphinx_log;
CREATE DATABASE kalturadw_ds;
CREATE DATABASE kalturadw_bisources;
Checking connectivity to needed daemons…
Connectivity test passed:)
Cleaning cache…
Populating DB with data… please wait…
Output for /opt/kaltura/app/deployment/base/scripts/installPlugins.php being logged into /opt/kaltura/log/installPlugins.log
Output for /opt/kaltura/app/deployment/base/scripts/insertDefaults.php being logged into /opt/kaltura/log/insertDefaults.log
Output for /opt/kaltura/app/deployment/base/scripts/insertPermissions.php being logged into /opt/kaltura/log/insertPermissions.log
Output for /opt/kaltura/app/deployment/base/scripts/insertContent.php being logged into /opt/kaltura/log/insertContent.log

kaltura-db.postinst FAILED with: 2545 on line 245

Archving logs to /opt/kaltura/log/log_14_04_20_15_09.tar.gz…

PHP Warning: require_once(/opt/kaltura/app/tests/lib/KalturaClient.php): failed to open stream: No such file or directory in /opt/kaltura/app/tests/standAloneClient/exec.php on line 263
PHP Fatal error: require_once(): Failed opening required ‘/opt/kaltura/app/tests/lib/KalturaClient.php’ (include_path=’.:/usr/share/php’) in /opt/kaltura/app/tests/standAloneClient/exec.php on line 263

Hello @Hudson,

This means that the client generation script, which runs as part of the kaltura-base postinst script failed to generate the needed clients.
This happens here:

I suggest you run:

# dpkg-reconfigure kaltura-base

Then, ensure that the clients were created under /opt/kaltura/app/tests/lib and /opt/kaltura/apps/clientlibs/. If they were, you can continue to redeploy the DB. You can do that with:

# apt purge kaltura-db
# apt install kaltura-db

If the files aren’t there, you need to understand why it fails. You can start by running

# php /opt/kaltura/app/generator/generate.php

manually and inspecting the output. If you see an error, post it here and I will assist you further.


Thanks for your help. I now see this in the installation log. I am guessing it is another fail.


electing previously unselected package kaltura-elasticsearch.
(Reading database … 281467 files and directories currently installed.)
Preparing to unpack …/kaltura-elasticsearch_1.0.0-1+b9_all.deb …
Unpacking kaltura-elasticsearch (1.0.0-1+b9) …
Processing triggers for systemd (229-4ubuntu21.27) …
Processing triggers for ureadahead (0.100.0-19) …
Setting up kaltura-elasticsearch (1.0.0-1+b9) …
-> Downloading analysis-icu from elastic
[=================================================] 100%
-> Installed analysis-icu
Waiting for the ElasticSearch daemon to start…
We’ve waited a minute and the ES daemon is still unreachable, we’re giving up:(
Processing triggers for systemd (229-4ubuntu21.27) …
Processing triggers for ureadahead (0.100.0-19) …
sed: can’t read /configurations/base.ini: No such file or directory

Hi @Hudson,

That one is because in

sed -i 's@\(exec_elastic\s*=\s*\)false@\1true@' $APP_DIR/configurations/base.ini 

But APP_DIR is not defined. I fixed this by adding:

. /etc/profile.d/

Right before the sed command.
That, however is a very minor issue. The bigger issue is that the ES daemon failed to start so you need to understand why that is. See

As stated in the issue:

ES is actually only utilised by the esearch service ( and, at present time, KMC and KMCng’s code do not make use of it so it isn’t a critical component for Kaltura CE.