Live Stream service requires flash on desktop

livestreamandbroadcast

#1

Hi i’m having a bit of a trouble with the live playback feature because it ask for flash installed and unblocked in chrome for my webpage. So in the live transmissions in desktop PCs without flash the player just says “Your browser does not support Live stream playback.” this is super annoying being an user because youtube or any other platform doesn’t ask for nothing and just works. There is some kind of work around or way to ask for adobe player to light on in the web page?


#2

Hi @gerardo_grimaldi, it seems like you are experiencing the wrong behviour.
The player supports native HTML5 playback, VOD and live.
Can you please share a link to a working example.


#3

I have a mail from the support team saying:

Hi,
Thank you for contacting Kaltura Customer Care.
Please note, the error you are experiencing with live playback (“Your browser does not support live stream playback”), is usually related to playback from desktops where flash is not installed.
Our Live Stream service requires either flash or HLS (iOS) playback.
This is why the desktop browsers that do not have flash installed cannot play the live stream.
In order to verify that lack of flash is indeed the cause of the issue, kindly use the following URL to test your flash version. If needed, please install or enable flash:
http://helpx.adobe.com/flash-player.html

Looking forward to your response.

For me this kind of behavior from a modern html5 player is unacceptable, to reproduce the error make an live stream and try to reproduce it deactivating flash and blocking flash from google chrome.


#4

@gerardo_grimaldi, as previously said, the player supports native HTML5 playback of Live and VOD streams.
It seems you are using either an old player or a mis configured player.
Unless you share a sample showing exactly what you are experiencing I’m afraid I wont be able to assist you, as I cant see what you are seeing.


#5

this… :frowning:

thanks


#6

@gerardo_grimaldi I’m not familiar with this system, as I said, I would require a test page or a shareable URL to review your setup


#7

@gerardo_grimaldi I checked your account. for some reason the player you have is set with the flag “disableHLSOnJs”=true, meaning native playback of HLS over MSE is disabled.
The player name is “Player final FWTV”.
I don’t know why this was set up like this.
The setup can be viewed in your KMC account in the player studio.
The section containng this config is under the plugins section in the UI Variables section:


You can either delete it, as it’s default is “false” or set it to false.
Again, I’m not aware to why this has been done, so please practice with caution when altering your config.


#8

I will try with that…


#9

check this one…enable flash player


#10

The problem was an UI variable that was on.

Thanks anyway!