Libzen dependency

Hey all,

I have some of my systems administrators working on a kaltura installation (v15.14) and they’re running into a dependency issue. It’s sort of puzzling to me, though, as libzen is included in the Kaltura repo and the epel repo.

I’m not sure why Yum is complaining as it seems the required package is in the Kaltura repo.

Here is the output

--> Finished Dependency Resolution
Error: Package: kaltura-libmediainfo-0.7.61-8.x86_64 (Kaltura)
Requires: libzen = 0.4.37
Available: libzen-0.4.36-1.el7.x86_64 (Kaltura)
libzen = 0.4.36-1.el7
Available: libzen-0.4.37-1.el7.x86_64 (Kaltura)
libzen = 0.4.37-1.el7
Installing: libzen-0.4.38-1.el7.x86_64 (epel)
libzen = 0.4.38-1.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

any help is appreciated. Thanks --dave

Hi @david.hahn1,

What happens if you first try to explicitly install libzen-0.4.37-1.el7.x86_64?


Thanks Jess, I think that took care of it!