KMC.mxml, KMC uiconf load failed: Error #2048

When trying to access my first publisher account after install I get the error in the title.
When I run /opt/kaltura/bin/ I get the error below. Everything else passes.

[Create Partner] [FAILED, RC: 255] - [.452188492]
Partner creation failed. I will skip all tests that require it.


To debug this, lets run the create_partner.php script manually.
First, get the admin_secret for partner -2:
# mysql -h$DB1_HOST -u$DB1_USER -p$DB1_PASS $DB1_NAME
mysql> select admin_secret from partner where id=-2;

Then call the script pass the value as <admin_secret>
# php /opt/kaltura/bin/create_partner.php <admin_secret> somepasswd $SERVICE_URL

Then paste the output here.


PHP Notice:  Undefined offset: 4 in /opt/kaltura/bin/create_partner.php on line 9
PHP Fatal error:  Uncaught exception ‘KalturaClientException’ with message ’ malformed’ in /opt/kaltura/web/content/clientlibs/php5/KalturaClientBase.php:357
Stack trace:
#0 /opt/kaltura/web/content/clientlibs/php5/KalturaClient.php(6300): KalturaClientBase->doQueue()
#1 /opt/kaltura/bin/create_partner.php(19): KalturaSessionService->start(‘user@domain…’, NULL, 2, -2, NULL, NULL)
#2 {main}
  thrown in /opt/kaltura/web/content/clientlibs/php5/KalturaClientBase.php on line 357

You seem to have missed some argument.
What was the full command you ran? please mask the secret when posting it.

I did

source /etc/kaltura.d/system.ini
secret = "mysecretadminkey"
/usr/bin/php /opt/kaltura/bin/create_partner.php $secret $SERVICE_URL

You are missing an argument and the order is wrong. Should be:

/usr/bin/php /opt/kaltura/bin/create_partner.php $secret thepasswd-for-new-partner $SERVICE_URL


Now I get this.

 /usr/bin/php /opt/kaltura/bin/create_partner.php $secret new_user_password $SERVICE_URL
PHP Fatal error:  Uncaught exception 'KalturaClientException' with message 'Peer certificate cannot be authenticated with known CA certificates' in /opt/kaltura/web/content/clientlibs/php5/KalturaClientBase.php:357
Stack trace:
#0 /opt/kaltura/web/content/clientlibs/php5/KalturaClient.php(6300): KalturaClientBase->doQueue()
#1 /opt/kaltura/bin/create_partner.php(19): KalturaSessionService->start('82c697680f294e9...', NULL, 2, -2, NULL, NULL)
#2 {main}
  thrown in /opt/kaltura/web/content/clientlibs/php5/KalturaClientBase.php on line 357

The problem is the SSL certificate configuration.
Is this a self signed cert? if so, that will explain it.
Also, did you make sure to input the CA as well? I suggest you consult the cert supplier.

My cert is from Digicert. I have it in a pfx file and extracted the crt and key to use in apache. This has always worked for me. I apologize for my ignorance but I have never had to import a CA as well. Could you possibly point me in the right direction? I thank you again for your time and patience.

Please look here for guidance:

Your provider should also be able to send you the CA bundle.

I found the command to make the CA file from my pfx file. Using the command below, I added the resulting file to zzzkaltura.ssl.conf ran the command again and Bingo, Bango, Bongo it worked. Jess, I owe you a beer. Thank you for your assistance. Greatly appreciated.

openssl pkcs12 -in domain.pfx -out domain-ca.crt -nodes -nokeys -cacerts

Surething, happy to help.