Kaltura player doesn't play

I installed Kaltura following the guide on the github page saying " Installing Kaltura on a Single Server (RPM)"

I can login into the platform and everything seems working good. I created a new publisher with success and then click on “action”->“Manage new”.

I can see 5 entries video.

When I navigate on the detail page of the first video, I see the thumbnail with the play button and if I click on it, it plays. I can see from the developer tools that a file a.mp4 is being requested

But when I navigate on the third video, the thumbnail gets loaded but when I try to plays it there is an error in the developer tools under network tab. This time the file requestes is a m3u8. The error for this request says “canceled” as status and it try every time to request this resource and always it get “canceled”

My Kaltura installation isn’t in SSL.
Apache running on 80
Vod packager running on 81
Nginx running on 8081

Obviously I think that port 81 is closed and for that I get the error. But when I go on the Database under delivery_profile table and chaning my port with 80 that’s what happen:

The request was sent with success but the player stops and there is that error on the console.
When I try to click play for the second time an error saying

{“type”:“networkError”,“details”:“manifestParsingError”,“url”:“linkToThe.M3u8”,“fatal”:true,“networkDetails”:{},“headers”:“accept-ranges: bytes\r\naccess-control-allow-methods: GET, PUT, POST, DELETE, HEAD, OPTIONS\r\naccess-control-allow-origin: \r\nage: 2\r\ncache-control: public, max-age=8640000, max-stale=0\r\nconnection: keep-alive\r\ncontent-length: 1810768\r\ncontent-type: video/mp4\r\ndate: Mon, 20 Sep 2021 10:36:28 GMT\r\nexpires: Wed, 29 Dec 2021 10:36:29 GMT\r\nlast-modified: Sun, 19 Nov 2000 08:52:00 GMT\r\npragma: \r\nserver:me\r\nx-kaltura: cache-key\r\nx-kaltura-session: 426620211, 1632134188\r\nx-me: \r\n”}

is shown

Can someone with any similar problem, help me?

Thanks in advance

Hi @MarcoCastano94 ,

Very short entries are served directly over HTTP, without the use of adaptive bitrate protocols. This is because for such entries, there’s no added value to using HLS, HDS or DASH.
The duration threshold is controlled by the short_entries_max_duration directive in /opt/kaltura/app/configurations/base.ini.
This would explain why short videos play correctly whereas longer ones do not.
By default, when the playback method is HLS, HDS or DASH, HLS being the default for entries longer than the value for short_entries_max_duration is set to, the Nginx VOD module is used to repackage the MP4 file as HLS and serve the manifest and segments.

You’ve written:

Vod packager running on 81
Nginx running on 8081

I am confused by this since the VOD packager is, in fact, an Nginx module.

Please refer to Install kaltura Nginx VOD module - #23 by eemirtekinn for a detailed explanation on how this works.


1 Like

Hi @jess,
thanks for the reply.

I re-installed and now I’ve got my Nginx running on port 88 and Apache on port 80.
In my delivery profile table, I have


But every request pass by a proxy and the only port available is 80.
I tried adding a proxy pass on zzzkaltura configuration file adding:

ProxyPass /hls/ http://mykaltura.it:88/hls/
and changing according delivery profile table, editing port 88 → 80

But I still have error of 404 nginx not found.
Can you help me adding a right ProxyPass rule?

PS. mykaltura.it is and example hostname for security purposes


Hi @MarcoCastano94 ,

Are no other ports open from the outside on this host? Note that you do not have to use TCP 88 for Nginx, you could choose any free port you’d like (for example, 8080 say).

If port 80 is the only available option, then yes, you could use Apache’s proxy module. If the rule doesn’t work, I’d start by inspecting the requests triggered when you hit ‘play’ and ensuring the HLS manifest URL is what you expect it to be and that the request reaches Apache. Then, check Apache’s logs to understand why the rule isn’t applied as expected.

1 Like

Hello @jess
With ProxyPass in Apache configuration I managed to do it. Now everything is working. Thank you!!

I can’t figure out, how to enabled “launch editor” instead. When I upload a video, “launch editor” options is disabled. Where I can enabled it?

Thank you again!

Hi @MarcoCastano94 ,

Glad we’re good on that point. With regards to the editor,it is not FOSS and can therefore only be used in SaaS/On Premise context. However, you can implement your own editor using the API.
Documentation for all the API services is available at developer.kaltura.com.
A script that makes use of the trimming/clipping APIs is available under /opt/kaltura/bin/clip_test.php, you can use that as a starting point.

1 Like