Kaltura Management Console (KMC) not working

I have recently installed Kaltura on Linux system. Now I am facing one issue with KMC, other modules are working fine but kmc page generating follownig error “The server returned a “500 Internal Server Error”” , so what should I do for this issue?

Thanks in Advance!


In the shell on the server, run:
# . /etc/profile.d/kaltura*base.sh
# kaltlog

Then make the request and look at the log to find the error.
In parallel, also open the dev tools in your browser and look at the errors under the console and network tabs. Once you have the error, we can take from there.

i can not find “kaltura” in /etc/profile.d directory


Then something is not properly installed…
What OS is this? how did you install?

My OS is Linux (Ubuntu) and i have followed one tutorial for it

For Ubuntu, the following should exist:
$ dpkg -S /etc/profile.d/kaltura-base.sh
kaltura-base: /etc/profile.d/kaltura-base.sh

If it does not, what is the output for:
# dpkg -L kaltura-base

I am getting output for dpkg -L kaltura-base is

"dpkg-query: package ‘kaltura-base’ is not installed
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents."

and my installation directory is /opt/kaltura.


Then something went wrong with your install.
Are you following this?

nope I am not following this
I have followed “http://www.avinit.fr/howto-kaltura-community-edition-ce-step-by-step-installation


This document is old and no longer relevant.
Please follow official instructions here:

nope i am not following this
I have followed “http://www.avinit.fr/howto-kaltura-community-edition-ce-step-by-step-installation


Not sure I understand your last comment… I understand that you tried using:
but this info is no longer valid. Please follow the link I provided.

Ok… I have also tried your provided link of GIT Hub but i can’t make comfortable with this site
The steps are too confusing I cant understand what it wants to do.

So can you please provide easier steps for Kaltura installation (Ubuntu) from the beginning?


Please explain exactly what you’re having difficulties with and we’ll be glad to help you.

I am facing issue with aptitude install kaltura-red5.
I am getting following error

"invoke-rc.d: initscript red5-server, action “start” failed.
dpkg: error processing package red5-server (–configure):
subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of kaltura-red5:
kaltura-red5 depends on red5-server; however:
Package red5-server is not configured yet.

dpkg: error processing package kaltura-red5 (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:


The red5-server package is an official Ubuntu package and is not provided by Kaltura. You should report this to the package maintainer.

aptitude show red5-server

Package: red5-server
New: yes
State: not installed
Version: 1.0~svn4374-3
Priority: optional
Section: universe/java
Maintainer: Ubuntu Developers ubuntu-devel-discuss@lists.ubuntu.com

Note that Red5 is only needed if you want to use webcam recording.

Other than this issue, do you now have a fully functional install?

ok i dont need Webcam recording so i should skip this, right?
and after that i am have still problem with KMC
it is loading now(Login page), after signing in it is giving connection error.
but after refreshing it by root page we can open KMC.

But it is just giving me a blank page with its header row of tabs(Dashboard content Application Studio etc)

Is the service URL you’ve used resolvable and available from both the server itself and the client from which you’re running the browser?
Open your dev tools console and the browser and look for failing calls under the network and console tabs and also, use kaltlog, as I indicated initially to check the errors in the server logs.

yes in my developer tools console it is having two errors as follows:

“Uncaught SyntaxError: Unexpected token <” in “KMC1:572”

“Uncaught ReferenceError: loadModule is not defined” in “functions.js:79”

OK. What do you see in the server log?