Kaltura CE livestream over 8443?

After setting up kaltura CE on a Ubuntu 16, everything seems to work except 1 thing.
I’m unable to use livestream on port 8443. If I drop ssl completly they work on port 88.
Also with ssl I can see that the kaltura player is seeing that there is a livestream, but ofc then i can’t play it because of mixed content. So it seems that for some reason the api call is not working?
http://<>:88/hlsme/test.m3u8 works and I get an islive=true response in KmC but doesnt play because of mixed content.
https://<>:8443/hlsme/test.m3u8 works and I get an islive=false response in KmC so it doesn’t play.

I’m pretty sure im overlooking something basic, because al other video. (the non livestream once) are working and using 8443.

Hello @gielbier,

Remember that hls streaming is just http. Check your nginx virtual hosts/domains and that they are consistent with a FQDN Kaltura can resolve. Maybe add the name to /etc/hosts with the right IP

Add a correct certificate for the https service and it should work.

You can use a different live delivery profile to the partner via the admin console (Live HLS, pointing to the hostname you want to use).

It’s more a point or having a consistent nginx configuration than anything else.

Hope this short explanation works for you.


Hi @david.eusse

I think the problem I am facing is indeed somewhere in the live delivery profile.
With VLC I get the stream both on :88 and :8443. But the kaltura player seems unable to see that the livestream is on, if I point it to :8443, but on :88 it works.

The problem it seems is that this call:

Always returns false when using :8443, and returns true on :88.

I’m pretty sure this is because of a setting, But am unable to find out which.

Hello @gielbier,

Please review this thread Install kaltura Nginx VOD module
If you can’t arrive at a solution after doing so, please post the configuration in the files referenced there, as well as the output for the commands I mention on that thread and I’ll assist you further.

If you can see the service on port 88 and not 8443, the cause may be related to a missing or bad certificate on kaltura-nginx.

Try to fix it using letsencrypt, por instance, and it should work.

You may also need to use these settings for your hls stream:

hls_base_url $http_x_forwarded_proto://$http_x_forwarded_host;