Kaltura CE 15.0.0 released

Hello all,

The latest version is now available.

kaltura-base (15.0.0) changelog:

kaltura-html5lib (v2.76)

  • FEC-9085 - need to click the pause button twice in order to pause the media
  • SUP-17081 - Styling issue with a player buttons dropdown menu
  • SUP-17365 - Encoding the “utility.referrer_url” in the adTag
  • SUP-17808 - no playback when selecting different source qualities

kaltura-kmcng (v5.9.1)

  • prevent passwords auto filling (#831) (d853051)
  • administration/multi-account: disable create button on error state (462881c)
  • administration/multi-account: fix adding website info when creating new account (cfbb7d4)
  • administration/multi-account: fix available accounts calculation (f270218)
  • entry/captions: support Luxembourgish captions (9cae1a9)

To upgrade, please follow:

RPM based:

Deb based:

Or, if running a cluster:

@jess After updating kaltura to this version, The entries are no longer listed in the partner dashboard although all entries play as normal in their embedded location but the entry listing is empty. How do I fix this?

Hello @ukadikestanley,

See my reply here: Categories not shown on KMC after upgrade
That thread deals with categories not being shown in KMC but the same is true to entries. Only, instead of kaltura.category, the relevant DB table is kaltura.entry. Running /opt/kaltura/bin/kaltura-sphinx-reindex.sh should fix it.

I tried reindexing sphinx but got this error instead.

PHP Catchable fatal error: Argument 1 passed to kSphinxSearchManager::saveToSphinx() must be an instance of IIndexable, instance of CaptionAssetItem given, called in /opt/kaltura/app/deployment/base/scripts/populateSphinxCaptionAssetItem.php on line 33 and defined in /opt/kaltura/app/plugins/search/providers/sphinx_search/lib/kSphinxSearchManager.php on line 532
Failed to run /opt/kaltura/app/deployment/base/scripts/populateSphinxCaptionAssetItem.php.
Please try to run it manually and look at the logs

Hello @ukadikestanley,

First of all, please run this:

mysql>  mysql -h $DB1_HOST -u $DB1_USER -p$DB1_PASS kaltura_sphinx_log < /opt/kaltura/app/deployment/updates/sql/2019_05_19_alter_table_sphinx_log.sql

If, following that, you’re still experiencing issues when running /opt/kaltura/bin/kaltura-sphinx-reindex.sh, please check for errors in /opt/kaltura/log/kaltura_api_v3.log and post the relevant log lines here.


The log file has a total of 7468253 lines and there are no errors but the above php fatal error still occurs upon reindexing of sphinx.

Did a reinstall. It works now. Thanks

This topic was automatically closed after 8 days. New replies are no longer allowed.