Kaltura CE 11.5.0 released

Hello all,

The latest version is now available.

Core changelog:

  • PLAT-4780 - Support generating packeger url format for external remote storage as well
  • PLAT-4776 - eCDN: SaaS KES Failover support
  • PLAT-4433 - Facebook authentication for Distribution Connector
  • PLAT-4434 - Facebook Distribution Configuration
  • PLAT-4435 - Distribute content metadata to Facebook
  • PLAT-4436 - Video distribution to Facebook
  • PLAT-4438 - Distribution of thumbnails to Facebook
  • PLAT-4862 - Optionally preserve original source when custom intermediate-source is used
  • PLAT-2502 - Ad Stitching: log all ad calls & ad beacons; create sample live event ad event audit
  • SUP-5785 - playManifest request, allows access from ‘unallowed’ domain
  • SUP-6009 - Getting the sent notifications data - users, mails etc.
  • SUP-6187 - Unable to get the category ids from API
  • PLAT-4097 - quiz.update fails when using format=9 (jsonp)
  • PLAT-4782 - EmailReport:cue-point.VAST/Creatives gets wrong value

Install scripts changelog:

  • Fix SSL deployment for RPMs

To upgrade, please follow:
RPM based:

Deb based:

Or, if running a cluster:

As always, your feedback is welcomed,

Hello, I installed the latest version CE 11.5.0 three times on clean Centos 6.7 with SSL as per instructions on page: https://github.com/kaltura/platform-install-packages/blob/master/doc/install-kaltura-redhat-based.md#ssl-step-by-step-installation

All 3 installation attempts resulting with the same error:

Running Batch config…

base-config completed successfully, if you ever want to re-configure your system (e.g. change DB hostname) run the following script:

rm /opt/kaltura/app/base-config.lock


Reloading httpd: not reloading due to configuration syntax error

kaltura-batch-config.sh FAILED with: 8854 on line 98

Archving logs to /opt/kaltura/log/log_04_01_16_18_30.tar.gz…
ERROR: /opt/kaltura/bin/kaltura-batch-config.sh failed:( You can re-run it when the issue is fixed.

Please advise. Thank you.


The issue here is that /etc/init.d/httpd reload fails. Start by looking at /etc/httpd/conf.d/zzzkaltura.ssl.conf and see what it looks like. Should be similar to:
SSLCertificateFile /etc/ssl/certs/rhel7.kaltura.org.crt
SSLCertificateKeyFile /etc/pki/tls/private/rhel7.kaltura.org.key
SSLCACertificateFile /etc/ssl/certs/ca-kaltura.org.crt

SSLEngine on
SSLProtocol all -SSLv2

    ErrorLog "/opt/kaltura/log/kaltura_apache_errors_ssl.log"
    CustomLog /opt/kaltura/log/kaltura_apache_access_ssl.log vhost_kalt

    Include "/opt/kaltura/app/configurations/apache/conf.d/enabled.*.conf"

Only with paths to your own certificates and key files and your own host.
This file is auto generated from /opt/kaltura/app/configurations/apache/kaltura.ssl.conf.template when running /opt/kaltura/bin/kaltura-front-config.sh

I recently made a fix in this area so make sure you have:

rpm -q kaltura-postinst


Hello, I manually added the paths of the SSL certs in /etc/httpd/conf.d/zzzkaltura.ssl.conf

[root@player conf.d]# rpm -q kaltura-postinst

kaltlog shows the following:

[Mon Jan 04 19:00:51 2016] [error] [client] File does not exist: /opt/kaltura/app/alpha/web/opt, referer: https://HIDDEN/admin_console/index.php/user/login
[Mon Jan 04 19:01:37 2016] [error] [client] File does not exist: /opt/kaltura/app/alpha/web/opt, referer: https://HIDDEN/admin_console/index.php/user/login
[Mon Jan 04 19:13:30 2016] [error] [client] File does not exist: /opt/kaltura/app/alpha/web/opt, referer: https://HIDDEN/admin_console/index.php/user/login
[Mon Jan 04 19:19:20 2016] [error] [client] File does not exist: /opt/kaltura/app/alpha/web/opt, referer: https://HIDDEN/admin_console/index.php/user/login

2016-01-04 11:51:24 [0.000000] [828517072] [1] [BATCH] [KSchedulerConfig->load] NOTICE: loading configuration /opt/kaltura/app/configurations/batch at 1451924325
PHP Fatal error: Uncaught exception ‘Zend_Config_Exception’ with message ‘Section ‘HIDDEN’ cannot be found in /opt/kaltura/app/cache//batch/config.ini’ in /opt/kaltura/app/vendor/ZendFramework/library/Zend/Config/Ini.php:150
Stack trace:
#0 /opt/kaltura/app/batch/scheduler/KSchedulerConfig.class.php(59): Zend_Config_Ini->__construct(’/opt/kaltura/ap…’, ‘HIDDEN’, true)
tail: cannot open `/opt/kaltura/log/batch/*.log’ for reading: No such file or directory

2016-01-04 10:26:50 [1545149009] [addPermissionsAndItems.php] [addItemToPermissions] ALERT: exception ‘Exception’ with message ‘ERROR - Permission name [BATCH_BASE] for partner [0] not found in database - skipping!’ in /opt/kaltura/app/infra/log/KalturaLog.php:65
Stack trace:
#0 /opt/kaltura/app/alpha/scripts/utils/permissions/addPermissionsAndItems.php(284): KalturaLog::alert(‘ERROR - Permiss…’)

Please advise. Thank you.

Also, there seems to be a problem with httpd:

[root@player conf.d]# service httpd status
httpd is stopped
[root@player conf.d]# service httpd start
Starting httpd: [Mon Jan 04 19:56:35 2016] [warn] default VirtualHost overlap on port 443, the first has precedence

Hello @mark

See if the note in my thread help resolve your issues with the overlap.

This topic was automatically closed after 8 days. New replies are no longer allowed.