Kaltura Batch Tasks disabled

Hey all,

I’m reviewing a newly installed Kaltura CE cluster and have noticed that all the batch tasks are set to a startup type of Disabled. I would have expected some to be automatic, some to be manual.

Is my expectation wrong or is something amiss with my configuration?

Hi @david.hahn1,

I assume you’re looking at Admin Console->Batch Process Control->Setup?
I’m afraid this particular view does not show the true state of things. There are a few such known issues we are aware of but I’m afraid I don’t have an ETA for addressing them.

If you want to configure or view the current enabled workers, please look at /opt/kaltura/app/configurations/batch/batch.ini.
On each batch node, under the [HOSTNAME : mainTemplate] section, there are multiple enabledWorkers.* directives. The value for each indicates how many of each worker should be run simultaneously.
Further down the file, you will see specific directives per worker.

Hey @jess

Yes, that’s the view I was referring to. Thanks for the information. Now that I think a little harder, batch logs are being generated for some batch tasks so they must be enabled. I’ll review the batch.ini file for more information.

Thanks for the reply!

Most welcome, Dave:)
Happy videoing,