Kaltura 5 Eagle html5 library upgrade to v2.0 causing no source video was found

Hi All,

I am newbie to kaltura and working with it for last two weeks. For the development purposes we have installed the CE5 version(Eagle) .

The version came with v1.5.9 of the html5 library.While trying we found that the kwidget wasn’t working with it so we used instruction as shown in this link.

The library version we are using is v2.0.0.

After installation the flash videos are working fine but the html 5 video shown no video source found error.Any help would be appreciated.

Please let me know if any more code/test page would be required and what would be guidelines to attach the code/testpage link.

Is Eagle the most recent version of CE ?

Have you edited the LocalSettings.PHP file in that libraby?


Sorry for the late answer. Eagle is the ce5 version(latest release) available. After that the site says to build the solution from Git repo.

Yes I changed the load.php url in the Localsettings .php.Thats why the flash version is working but the html5 says the source video not found.

The HTML5 library is probably looking for an updated version of the entry response. I don’t have the version number off hand that is compatible with Eagle, if at all possible running a more recent version would be ideal.

You could try a 1.7.x version.

Hi Mdale,
Thanks tried with 1.7.2 and the result was the same.Can any one suggest from which version the kwidget support started?

Hey all, i have Kaltura CE6 installed and already have tried several HTML5-libs (1.9.3, 1.9.6, 2.0.2, 2.0.3) and all of them are not working cause the error “No source video was found” appears. in my LocalSetting.php i have configured “$wgKalturaServiceUrl”, “$wgKalturaCDNUrl”, “$wgKalturaCDNUrl” to my kaltura CE6 instance. What could be the solution, i want to use the current lib because it looks and feels much better…

thanks for any help

I’m having the same issue. I updated the html5 lib to v2.1.1 to enable mobile, but i got the “No source video was found”. Same thing happening with v1.7.0.4, but with this version, the name and the snapshot of the movie appear, so it’s getting the info from the server. What could be the solutionto this problem?

Kaltura CE 9+??? i thought the current version of Kaltura is “Falcon 6” which is still in beta… or not?

I saw the v9+ on github, but there’s no documentation at all on how to install it. The only documentation I found for installing trough Github is for Falcon 6 (at https://github.com/kaltura/ce-packager/issues/35) is it posible to try v9?

Thanks oferc, We will definitely check it out and let you know.

I got stucked at one point… After fullfilling the requirements, the install.php gets the server from github, and then it does a svn checkout… and after that, tries a ssh connection to kelev.kaltura.com, giving the following error:
connect to host kelev.kaltura.com port 22: Connection refused
I already checked port 22 to be open, and i’m lost after this point. Did you had any luck installing it?

Is this an issue with upgrading the overall platform or using the kaltura player library 2.0?

This could also be related to issue #710 I reported on the mwEmbed GitHub page.

(For some reason I’m not allowed to post a link to GitHub!)

Have you guys found a solution yet?


Eagle is very old and is no longer supported.
Please install using this proc:

It should allow you to use the latest lib which is actually part of the kaltura-htm5llib RPM.

Do let me know should you have issues


Hi there,
You might also need to upgrade the API_v3 services for getting the entry info and flavours.
Those were changed between CE5 and the current CE.

You should have a look at: service: baseEntry -> action: getContextData, it might be missing or different than the one you have.

You might have it under flavourAsset or something like that, you can see that when the player loads.

cool place nice to see everyone helping each-other and solving problems good guys