Kaltura 11.17 Batch issues cluster with SSL

Dear Team.
I’m confronted with the following issues with the cluster installation.
I have front node with ssl
mysql server with sphinx and dwh
nginx server
batch server

The issue is batch does not work but this due to the fact:
[root@batch1 html5]# curl -I $SERVICE_URL/api_v3/index.php
HTTP/1.1 404 Not Found
Date: Fri, 24 Jun 2016 16:07:55 GMT
Server: Apache/2.2.15 (CentOS)
Connection: close
Content-Type: text/html; charset=iso-8859-1

But in the browser the link https://portal.servcast.net/api_v3/index.php it gives the API request as required.
In /opt/kaltura/app/configurations/batch/batch.ini

service url is http://portal.servcast.net, but the result is the same.

The apache configuration is zzzkaltura -> …/apache/zzzkaltura.conf – this has the ssl certs and the vhost on 443
kaltura_redirects.conf ->apache/kaltura_redirects.conf which has the redirect rule and the vhost on port 80

Please advise.
Kind regards.

Edit: Thinking that the ssl is throwing the API requests offguard i removed the ssl configuration, removed the redirect link remove the ssl kaltura link , did a symlink to kaltura.conf and etc…

Now curl gives:
curl -I $SERVICE_URL/api_v3/index.php
curl: (7) couldn’t connect to host

But http://portal.servcast.net/ works.
Everything works.
Can you please tell me where the files that define this variable so i can manually replace.
If i do:

So this means it cannot do the requests via https, now can someone please tell me where this is defined so i can change it.
Jacob R,


im not shure if this helps
but, in your ans file set http to be port 80 not 443 and protocol http and not https
then manually you can create an httpd conf file manually to configure SSL

these steps solved me problems with https for a long time.


Thanks for the reply, i will try.

@aquileasfx1, i really appreciate the help, can you give me a few more details on how you configured your http file.


sure its going to be a pleasure,

after you finished setting up the kaltura server with httpd and not https
you will have a symbolic link under /etc/httpd/conf.d right?

that points to the http config file of kaltura
like this:

zzzkaltura.conf -> /opt/kaltura/app/configurations/apache/kaltura.conf

what you have to do, is to edit this: using your relevant data:

and then create another symbolic link under the confid.d folder of httpd
like this:
zzzkaltura.ssl.conf -> /opt/kaltura/app/configurations/apache/kaltura.ssl.conf

restart httpd and that should do it

I hope this helps


I really appreciate all the support, thanks Bryan, but i wen’t with a load balancing solution, so the https goes untill the load balancer, the servers also have vlan so i’m doing ssl ofloading from the balancer inside the cluster so it simplified my setup from that perspective.
Again thank you.
This thread can be closed.