iFrame Embedded video not playing

I am using a CentOS 7 instance on AWS EC2.
From the KMC dashboard I copied the embed iframe code and tried to play it on a web page. The thumbnail and video player loads fine but when I click play the video does not play.
When I checked the console it’s trying to load from the AWS internal ip address and not the public ip.
I ran the config script and used the public ip address in the setup, checked the Nginx config and even changed the hostname
For example: http://ip-12-34-56-78.us-west-2.compute.internal:88/hls/p/100/sp/11800/serveFlavor/entryId/0_awtkd4jt/v/2/ev/2/flavorId/0_3bt7h1va/name/a.mp4/index.m3u8


The hostname you posted does not look like it’s a publicly available/resolvable domain. I certainly can’t reach it and it ends with ‘internal’. Which, while not conclusive proof, would indicate it’s well… internal.

Are you able to reach this hostname from your browser or using curl CLI?


When I tried playing the video using the Javascript player it tries to load from this url:

However if I change the domain from ip-172-26-10-90.us-east-2.compute.internal to use the IP address of the server it works fine.
I updated the URL in the database to the IP address and it still tries to play the video using the domain.

These were the rows I updated in the database:
select id,name,url from kaltura.delivery_profile where id in (1001,1002,1003);

This is the Javascipt code for the player:
kWidget.thumbEmbed(‘player’, {
targetId: ‘player’,
wid: ‘_103’,
uiconf_id: ‘23448318’,
entry_id: ‘0_kldujvrr’,
readyCallback: (player_id) => {
console.log(‘player ready’);

The sample videos that came with the dashboard play without any problem it’s only the new videos that I upload cannot be played. I ran the Nginx config script again and even changed the hostname on the server to the IP address

I can’t access the server by the hostname, only by IP address. How do I change this so that the URL generated use the IP address.


See https://github.com/kaltura/platform-install-packages/blob/Propus-16.11.0/doc/kaltura-packages-faq.md#changing-apache-configurations-post-install