I give up enough is enough folks kaltura is not for the simple man i guess

I have been at this for about a week just trying to get thru the config process and after i finally think i got it down to the last step to pass, now im right back at square one and its not accepting my root password. So you know what i really hate to say this because i know that the devs at kaltura really have a great idea here. But enough is enough folks, there should be no reason any software should be so complicated to install.

I hate to say this because i work hard on my scripts as well but the difference is that i put all the complicated stuff in the background or part of the next phase after its installed, and i never expose the user to a configuration process that is so huge and can break at any step and then we start all over again. Why not split up the process so we dont have to keep doing configall, every time.

I get it ok, the software is suppose to be powerful, but whats the use of all that if it takes a server admin with years of experience to install it. If your reaching for the common man your missing your market because the common person could not install this.

The install needs to be web based.
Dont do all the complicated stuff at first, stick to building the db and get the thing installed.
Then once its installed then you can worry about mont and all the other dependentcies you need that goes with it. I dont even understand why you have to use all the special modules just to install it. I have written alot of software and none of it ever included so many special modules or ever asked for a root password. Why not just have it like all web based installs. A few questions, the db info, and boom done.

Then the next phase after logging into the admin panel would be the other stuff.

Give the user the satisfaction of getting it installed quickly. Then if there is more to do, that can be done after they get into the admin panel. But to have the whole process command line and all in one step pass fail is miserable and not the most efficient way to do an install.

Anyway i have a headache, i have waisted enough time with this, i am removing it now and i wont be back until i know you have redeveloped it either in sections to config or you have made it so that the common person can install it.

Good luck.

Hello @durangod,

Kaltura is a complex server side product that involves many moving parts and multiple FOSS components. That said, the installation is not hard to complete on a clean ENV and many people w/o much system administration experience manage to complete it successfully and happily use the product. I do want to help you get to that stage.

As to:[quote=“durangod, post:1, topic:5681”]
Why not split up the process so we dont have to keep doing configall, every time.

You do not HAVE TO RUN kaltura-config-all.sh each time, if you look inside, you will see it is a wrapper that calls each node configuration role in succession. You can run each of these steps individually to debug.

It cannot be. As I said, it needs to perform multiple operations that require super user privileges, such as installation and configuring multiple servers [MySQL, Sphinx, Apache, etc] and restart daemons. Doing so from a web I/F would be very insecure, not to mention annoying because if you accidentally close your browser window or your browser hangs, you won’t be able to tell what happened last and resume it. But really, the security considerations are enough of a reason not to try it. In addition, in your case, with the different PHP versions and incompatible MySQL version, it would not have helped at all.

The modularity of different config scripts per role [front, batch, DB, Sphinx and DWH] is also mandatory for a cluster install, where the kaltura-config-all.sh is not used at all.

In your various posts, you noted several problems on your machine, among which, several different PHP versions, a MySQL server that did not come from the official distro repo, etc.

I think it would be easier for you to use Vagrant or a Docker container to get things working.
For Vagrant, see:

For Docker, clone the repo locally and see:

and this Dockerfile:

Alternatively, you can start a clean server with any one of the supported distros [RHEL/CentOS 6 or 7 or Ubuntu 14.04] on AWS, Rackspace or any other cloud service and run through the install process again.

If you run into issues, please report the exact command you ran and the output and try to keep it all in one thread to make it easier to track.

If you are willing to try, I will be happy to help you with it.

Hi jess,

Thanks for the reply and the offer. Yes it is true that some of the issues i was having had nothing to do with Kaltura but rather my lack of experience on the server admin side of things. I just made my 2nd payment on the server and still dont have web files installed yet which is frustrating in itself.

In that time i have had to wipe the system twice. The first time i installed something i should not have and to be sure i had a clean system again i had it wiped. The second time i sadly locked myself out of my own server trying to secure it and so the server company set it up under recovery mode but after reading and watching vids i still had no clue what to do with recovery mode so i just had them wipe it again.

Then it came to PHP and MySQL which have been a thorn in my side since the first day and getting them updated. I could not find a RPM and was told i would either have to use a different respository which was not the best thing to do or build them from scratch from source. So yes i used to have the old MySQL and the old version of PHP when i first tried Kaltura And then during the process i thought i had updated PHP from source and it turns out i just installed a separate install. And then with MySQL i had to do it separately as well to get it updated.

So after chasing my tail round and round on how to update the PHP i finally decided to just go with the remy repository way and just do it, and now that has been done. PHP is now updated, there is no more 5.3 on the system, all the files show 5.5 now and there is only the one version. Why PHP, MySQL, and Apache dont offer RPM like the other repositories do i dont know but it was a very frustrating experience.

I made alot of mistakes along the way, such as leaving safe mode turned on which didnt help matters, and also uncommenting all the windows dll extensions in the php ini file and then wondering why they system could not find them, then it finally dawned on me duh those are windows files no wonder.

I printed out the phpinfo from my other host and then went line by line top to bottom of my php ini file and compared the values. After all that there are only three main differences now. One is the curl ssl version which they have openssl and i have NSS/3.21 Basic ECC, and i have openssl installed, but i am told that i would have to rebuild curl to change it and i dont want to do that. From what i have read so far does not really matter as much as it used to because NSS now supports more than it did before. And the second item is the mysql client API version which theirs shows the version number and mine shows mysqlnd which again from what i have read is that mysqlnd is common practice. The third thing is that they have suhosin and i do not. So now after all this time i feel i have all the basic needed applications in place for the basic server process.

The main frustrating things i had with Kaltura were that even with the old version of the other softwares i still ran into issues with the following.

  1. having to hardcode my root pw and other data into the db config file because otherwise it would not take it.
  2. having to mod the kaltura http and https templates and conf files so that i could get it to work along side of my webmin/virtualmin install. Kaltura wants to consume the virtual hosts and 80 and 443 ports by itself and so if there is any other virtual host (as there is with my current installs) then i get the warning about cant share *ports and non * ports.
  3. the curl warning about not accepting my certs was driving me nuts, i dont have any issues with my certs for anything else so why curl.
  4. Mont constantly saying its starting at * port when i have set that up a few times with my ip and not *
  5. Logs especially the permission log which was so huge i could not even open it to see if there were any issues.
  6. Whatever propel is it seems to be integrated into everything and seems to fail more often than not.
  7. And thinking i had to do the configall every time, i bet i ran that at least 20x.

I still feel that once the db is created there should be no reason to create it again. And once its populated there should be no reason to populate it again.

I gave you the long version here because i wanted to help you to understand what has transpired since i have had this server and basically some of the things that led to my frustration overall. Not all of it was Kaltura but some of it was and it was just not a great experience for me so far.

So i hope you understand why at this time i have to pass on your offer to assist me in getting this setup. You said that Kaltura has many parts moving together, to me that means more time micro managing a server when that is not what i do to make income. So the more basic i can keep the server the better.

One thing i have learned from this experience (server admin) is that when something breaks its not just fixing one thing, its fixing 4 or 5 things and what might seem simple becomes days of research to fix an issue. I dont have a staff its just me so i really think at this time i have to pass on Kaltura. It is a great idea behind the project and i wish you all much success.

I will just install FFMPEG and live with that for the time being, one day i may give Kaltura another try when i need more features and lets hope by then my experience will be improved in a big way that such issues as i have had will no longer be issues.

Thanks :slight_smile: