How to setup VPAID JS Tag on Player HTML5 when used Flash Player in default?


How to configure a HTML5 player when i use by default Flash player ?



Go to KMC->Studio and either create a new player [all players created by Studio will be HTML5] or upgrade the existing Flash one. Personally, I recommend testing the HTML5 player before upgrading the existing since you cannot revert that.

My advertising agency forces to use Flash player for VPAID Swf and HTML5 Player with VPAID JS if the browser does not have.

But how to config HTML5 player link with Flash player ?

Because clicking on the html5 player with the same id (23448370) I have an error (screenshot)

Please help…

How to setup VPAID JS Tag on Player HTML5 when used Flash Player in default ??

Flash Player in first with VPAID SWF and if flash is’nt active on browser HTML5 Player start.

You should use our latest HTML5 video player - you can create a new one in the Universal Studio (not the old Flash Studio).
Use our DoubleClick plugin (available under the monitization category on the left) to add the ad tag. It supports both Javascript and Flash VPAID playback.
If your ad tag is a doubleClick adTag, put it in the Ad Tag URL field in the DFP Trafficking tab.
If your adTag is not doubleClick, select the VAST Trafficking tab and put the adTag in the Preroll URL field.
If you still can’t get it to work - please send us the adTag you are using and we will take a look.



if i used VPAID JS it’s ok but I must absolutely use VPAID SWF doesn’t work.

adTag VPAID SWF (is not DFP):

adTag VPAID JS (is not DFP):

I see both links work fine when put in the DoubleClick plugin using any of the 2 options I specified (DFP trafficking and VAST trafficking). Note that you must put the adTag in only one of these 2 options and not in both of them.

VPAID SWF is setup on VAST > Preroll URL play directly video no ads.

Ad I said, please use the DoubleClick plugin (below VAST plugin in Studio) instead of the VAST plugin. Make sure to uncheck the VAST plugin and check the DoubleClick plugin (keeping both checked will cause unexpected behaviour).

Great ! it’s ok :slight_smile:

To finish, have you got a idea to configure VAST SWF adtag in first and if Flash not active on browser VAST JS in second on DFP Plugin ?

Well, this is not a feature which is supported by the plugin itself. You can achieve this by checking if Flash is available in your Javascript before calling the Kaltura embed command. Once you know if Flash is available, you can decide which adTag to use. Then you call the embed command and set the correct adTag URL in the doubleClick plugin configuration using Flashvars. Hope that makes sense to you.


I have another problem, sometime player with playlist doesn’t work when adtag vast is empty…

I feel that the concern comes from ads configuration DFP ?

If you udon’t have an adTag - I suggest not loading the plugin at all. Simply pass “plugin”: false to the doubleClick plugin to prevent it from loading in such case.
Also - check the console for messages and errors to see what is going on.

i think player bug only when i do a video playlist with VPAID Adtag is true.

How to check in the console (ssh or admin_console) ?

I mean the browser console to check if there are any Javascript errors.

What is it ?