Fresh Community edition install nginx error

Hi i have made a fresh installation of the community edition on an all in one server.

My only problem is that html5 player does not work for large clips that need nginx, preview image is there but hitting play never starts playback.

Also i noticed that embed code is always wrong the url starts with https://http://…

Any help will be appreciated

My setup is an ubuntu 16.04 server

Edit: Nginx is not running properly here is the error
● kaltura-nginx.service - LSB: starts the nginx web server
Loaded: loaded (/etc/init.d/kaltura-nginx; bad; vendor preset: enabled)
Active: failed (Result: exit-code) since Tue 2020-02-11 18:15:57 CET; 1min 26s ago
Docs: man:systemd-sysv-generator(8)

Feb 11 18:15:57 kalturasrv systemd[1]: Starting LSB: starts the nginx web server…
Feb 11 18:15:57 kalturasrv kaltura-nginx[20418]: Starting nginx: nginx: [emerg] invalid host in upstream “http://kalturasrv..” in /opt/kaltura/nginx
Feb 11 18:15:57 kalturasrv kaltura-nginx[20418]: nginx: configuration file /opt/kaltura/nginx/conf/nginx.conf test failed
Feb 11 18:15:57 kalturasrv systemd[1]: kaltura-nginx.service: Control process exited, code=exited status=1
Feb 11 18:15:57 kalturasrv systemd[1]: Failed to start LSB: starts the nginx web server.
Feb 11 18:15:57 kalturasrv systemd[1]: kaltura-nginx.service: Unit entered failed state.
Feb 11 18:15:57 kalturasrv systemd[1]: kaltura-nginx.service: Failed with result ‘exit-code’.

Hello,

In the kaltura-nginx postinst phase, you are prompted for:

Your Kaltura Service URL
As the description reads
make sure to insert the host and port WITHOUT the http[s]:// prefix

Is it possible that you have included the proto? If so, you can easily reconfigure with:
# dpkg-reconfigure kaltura-nginx

Also, see Install kaltura Nginx VOD module
Cheers

Hi just to be clear As Kaltura Service Url i enter it without https://
Also which port to use in a non ssl environment. it prompts for 88 so i enter myserver.bla.gr:88 is that correct?

Well it seems i had much better luck installing on centos 7 and making sure all the prerequisites other there.
I got a new ssl certificate for my installation but adding the crt file and the private key to apache during installation fails with issuer certificate error.

Any clue on how to use the ssl certs will be helpfull.

Hello,

When prompted for the SSL cert and key (kaltura-front-config.sh in the RPM version), did you also input the CA cert? If not, you should.
For Nginx (`kaltura-nginx-config.sh in the RPM version), there’s no separate directive for the CA, you need to concat it onto the crt/pem file (from your description, it seems as though you haven’t even reached the Nginx config part yet but I’m writing this for future reference).

If you’ve done both and it is still not working, provide the relevant config files for both Apache and Nginx (paths are stated in the post I referred you to) as well as the output for:

$ curl -v $SERVICE_URL

Well i do enter cert , key , CA and the result is as follows

PHP Fatal error: Uncaught KalturaClientException: failed to unserialize server result

400 Bad Request

Bad Request

Your browser sent a request that this server could not understand.
Reason: You're speaking plain HTTP to an SSL-enabled server port.
Instead use the HTTPS scheme to access this URL, please.

in /opt/kaltura/apps/clientlibs/php5/KalturaClientBase.php:401