Error occurred during flavor processing



All of a sudden I am getting an error “Error occurred during flavor processing” when any video is loaded into the Kaltura. All still images are also not being processed. We are on Kaltura CE 11.12.0. Is this is listener that has stopped working?


Hi @steve_corey,

My guess would be your batch daemon is not running.
# /etc/init.d/kaltura-batch status
if it’s not running, try:
# /etc/init.d/kaltura-batch start
if it fails to start, take a look at the log file to understand why: /opt/kaltura/log/kaltura_batch.log


Thank you so much! It was not running.



Hi Jess, I’ve to struggle exactly with the same issue, but I don’t want to open a new topic for this.
The error during flavor processing seems to happen specially when a vob file was uploaded to the kaltura server. For a long time it says converting and then the error occured.

If I try to check the batch status with #/etc/init.d/kaltura-batch status it says that the job is running.

Any suggestion what I can do for further investigation?

Thanks in advance,


Hello @daniel_mueller_1,

Start by going to Admin Console->Batch Process Control. Input your entry ID and check what stages passed successfully and where it failed.
Next, look at the logs under /opt/kaltura/log/batch/ where each batch worker has its own dedicated log and error log. Check both for the following patterns “ERR:|PHP |Stack trace:|CRIT|[error]”, like so:
# grep -A 1 -B 1 --color “ERR:|PHP |Stack trace:|CRIT|[error]” /opt/kaltura/log/batch/*.log

Then, go into the actual log files and look at the lines leading to the final error and report back here with the findings.




Hi Jess,

Thanks for your suggestion with checking the Batch Process Control.
It seems that the source media file is corrupt.

If I start a trace I got the following error:

video errors: 1105#Product invalid duration - product(1150 sec), source(95 sec).
audio errors: 1105#Product invalid duration - product(1150 sec), source(95 sec).

I did open the vob file with VLC media player and the duration showed 95 seconds instead of 18minutes!
I did recheck the source video file with a media info tool.
Duration 1.35

Because of that we have to recheck some media source files, and I think kaltura itself seems to be fine.

Just one thing! While I was checking the logfiles I’ve discovered thousands of such files and that kaltura consumed plenty of gigs of free space. Is there a way or setting that kaltura automatically delete this logfiles from time to time?

Thanks and kind regards,


Hi @daniel_mueller_1,

By default, the system does not delete any log files but it does rotate and compress most of them. The log rotation is defined in configuration files under /opt/kaltura/app/configurations/logrotate and symlinks are created in /etc/logrotate.d/kaltura_*.

You can delete the conversion logs created under /opt/kaltura/web/content/entry/data///log if you’ve already reviewed them and wish to clear space. These logs are there for investigation purposes and the system does not need them in order to function. The only logs that are important to keep until the analytics process is done are the Apache access logs under /opt/kaltura/log/kaltura_apache_errors.log because they are used to populated the DWH tables with analytics data. When deleting logs, please be sure to never delete directories because they must have specific permissions [usually kaltura.$APACHE_USER, 775] in order for things to work correctly.