Change the maximum upload size

How do you change the maximum upload size in Kaltura? I’m getting the following error:

Some of the files exceed the current file size limitation for uploading (currently set to 2047 MB). Please import these files to the system by utilizing other ingestion options (e.g. bulk upload)

I’m using Upload from Desktop feature in Chrome on my Mac.

Hi @ifeatu,

KMC is Flash [though we are now working on an HTML5 and JS version which would be released soon] and Flash has a 2G upload limit. In addition, the Kaltura server is written in PHP, which, up until PHP version 5.6 [] also had a 2G upload limit.

If you wish to upload larger files, the following options are available:


@jess When I view the Content dashboard i dont see a “DropFolder” option where it should be Is this something I have to activate?

Hi @ifeatu,

Drop folders can be created from the Admin Console->Publishers->Your Partner->Profiles->Drop folders.

Hi @jess,

When estimate will you release html5 version of KMC?

1 Like

@jess I’m getting this when I try kmc please advise. This is a virtual instance in cloud NOT docker it’s Ubuntu.

Hi @ifeatu,

If you’ll open your browser’s dev tools, you’ll see the following get HTTP 403 [forbidden]:

This is why it does not load.

@jess Do I need to upload those js files there? That’s the cdn

Hi @ifeatu,

Yes, if you want to load KMC from CDN then you should upload /opt/kaltura/app/alpha/web/lib/ to it.
Along with other additional files.
Best way to debug these things is by simply opening your browser’s dev tools, trying to load KMC and looking at both the “Network” and “Console” tabs for errors/failed requests.

@jess any doc on what else needs to go in cdn? What all needs to go there?