Universal Studio Player suddenly broken

Can’t play any video with Universal Studio Player and can’t update any flash players to universal studio.

When I try to play a video using universal studio all I get in the spinning kaltura logo. This was working a couple of days ago, and I have done nothing as far as I know so this is very odd.

When I try to upgrade a player from flash to universal I get this error:

[Tue Dec 16 09:54:47 2014] [error] [client] PHP Fatal error:  Uncaught exception 'Exception' with message 'An error occurred when trying to retrieve uiConfFile' in /opt/kaltura/web/html5/html5lib/v2.22/modules/KalturaSupport/UiConfResult.php:89\nStack trace:\n#0 /opt/kaltura/web/html5/html5lib/v2.22/modules/KalturaSupport/UiConfResult.php(43): UiConfResult->loadUiConf()\n#1 /opt/kaltura/web/html5/html5lib/v2.22/modules/KalturaSupport/KalturaCommon.php(122): UiConfResult->__construct(Object(RequestHelper), Object(KalturaClientHelper), Object(KalturaCache), Object(KalturaLogger), Object(KalturaUtils))\n#2 /opt/kaltura/web/html5/html5lib/v2.22/includes/Pimple.php(122): {closure}(Object(Pimple))\n#3 /opt/kaltura/web/html5/html5lib/v2.22/includes/Pimple.php(83): {closure}(Object(Pimple))\n#4 /opt/kaltura/web/html5/html5lib/v2.22/modules/KalturaSupport/apiServices/mweUpgradePlayer.php(10): Pimple->offsetGet('uiconf_result')\n#5 /opt/kaltura/web/html5/html5lib/v2.22/services.php(30): mweUpgradePlayer->run()\n#6 /opt/kaltura/web/html5/html5lib/v2.22/services.php(21): mwEmbedApi->handle in /opt/kaltura/web/html5/html5lib/v2.22/modules/KalturaSupport/UiConfResult.php on line 89, referer: https://emlnx-media1.emcc.edu/apps/studio/v1.9.1/index.html

I tried to update the machine and this is what happened when I tried to update the database

Error occurred during DB update:
         || ERROR 1091 (42000) at line 1: Can't DROP 'entry_id_index'; check that column/key exists || ERROR 1050 (42S01) at line 1: Table 'drm_policy' already exists || ERROR 1091 (42000) at line 17: Can't DROP 'profile_id'; check that column/key exists || ERROR 1060 (42S21) at line 1: Duplicate column name 'root_job_id' || ERROR 1050 (42S01) at line 1: Table 'delivery_profile' already exists


What is the output for:
# rpm -q kaltura-html5-studio
# rpm -q kaltura-html5lib
# rpm -q kaltura-base

Also, can you please run:
# kaltura-sanity.sh


Jess, My apologies, please disregard this thread. Later that night, I tested on a different machine and everything appeared to be working fine. For some reason, none of the browsers on my machine would play any Universal Studio videos (IE, Firefox, Chrome). Very odd. I did do a flash update yesterday morning, but I find it hard to believe this would cause issues.

I did have problems with my update and have filled out a new issue here.