Unable to access player Universal Studio in KMC

I have Kaltura 10.10 installed on Debian 8.
When I go to the Universal Studio in the KMC the page loads but displays this error along with a login prompt.

You must login to use this application

I try using my kmc login but I keep getting the same above response. No apparent errors show up in the apache logs. The only message in the Chrome console is

The specified value '!' does not conform to the required format.  The format is '#rrggbb' where rr, gg, bb are two-digit hexadecimal numbers.   angular.js: 6

Maybe I missed configuring something?

Hello @jramer,

Can you make sure the studio_version in /opt/kaltura/app/configurations/local.ini matches your actual version and dir name under /opt/kaltura/apps/studio/
If not, adjust it and reload apache.
Please also check /opt/kaltura/apps/studio/v1.9.7/studio.ini
and make sure it too has the right version for itself and for HTML5, ver for that you can check with dpkg -l kaltura-html5lib
Then, please rerun:
php /opt/kaltura/app/deployment/uiconf/deploy_v2.php --ini=/opt/kaltura/apps/studio/v1.9.7/studio.ini --user=www-data

And reload KMC.

I verified that the studio_version is v1.9.7 in each of the files you mentioned. So that is correct.

dpkg -l gave me a version of 2.30-1, but the version in studio.ini was 2.30.2. Slightly different so I tried changing the version in studio.ini to 2.30.1 (in both locations where the version is used), ran the php script, logged out of the KMC, refreshed the browser and logged in again. Still got the same error message.
I tried the same process again changing the version to 2.30 in studio.ini but got the same results.

Considering the DB issues I was having earlier, maybe I need to reconfigure the kaltura-html5lib and kaltura-html5-studio packages?

Here is a screenshot of the error screen.

Do you have the /opt/kaltura/web/html5/html5lib/v2.30/ dir?

If so, please try:
# dpkg-reconfigure kaltura-base
# dpkg-reconfigure kaltura-front

If not, then we may need to reinstall kaltura-html5lib

That fixed it! I probably had not reconfigured kaltura-front since fixing my virtual host issues during the installation.

Thanks Jess!

Surething. Happy to assist.