Two problems installing

I have two problems installing Kaltura:

  1. When using a file .ans console displays the following:
    `Configuring your Kaltura DB…

`Checking MySQL version…
Ver 5.5.47-MariaDB found compatible

CREATE USER kaltura;
CREATE DATABASE kaltura_sphinx_log;
CREATE DATABASE kalturadw_ds;
CREATE DATABASE kalturadw_bisources;
Checking connectivity to needed daemons…
Connectivity test passed:)
ERROR: Couldn’t make an API request to http://XXXXXXXXXXXX/api_v3/index.php?service=system&action=ping.
Please check your setup and then run /opt/kaltura/bin/ again.`

attached content command curl -I -v http://XXXXXXXXXX/api_v3/index.php?service=system&action=ping

`* Trying…

Connected to ( port 80 (#0) > HEAD /api_v3/index.php?service=system HTTP/1.1 > User-Agent: curl/7.29.0 > Host: > Accept: / > < HTTP/1.1 404 Not Found HTTP/1.1 404 Not Found < Date: Tue, 26 Jul 2016 19:49:32 GMT Date: Tue, 26 Jul 2016 19:49:32 GMT < Server: Apache/2.4.6 (Red Hat Enterprise Linux) OpenSSL/1.0.1e-fips PHP/5.4.16 Server: Apache/2.4.6 (Red Hat Enterprise Linux) OpenSSL/1.0.1e-fips PHP/5.4.16 < Content-Type: text/html; charset=iso-8859-1 Content-Type: text/html; charset=iso-8859-1

Connection #0 to host left intact
[1]+ Done curl -I -v`

And the command apachectl -t -DDUMP_VHOSTS

Passing arguments to httpd using apachectl is no longer supported. You can only start/stop/restart httpd using this script. If you want to pass extra arguments to httpd, edit the /etc/sysconfig/httpd config file. VirtualHost configuration: *:443 (/etc/httpd/conf.d/ssl.conf:56) *:80 (/etc/httpd/conf.d/zzzkaltura.conf:1)`

  1. if I delete the file /base-config.lock basic configuration process starts, but when you reach the time zone the following error message:

Your time zone [see]: America/Bogota Bad Timezone value, please check valid options at

it should be noted that my time zone has been verified and is found in the above code , however I have also tried other as COT and PDT, America / New_York , have made the area between ’ ’ and between ’ ’ and has not I worked.

I resolved " in theory " one of the issue , but now in the installPlugins.log displays the following error:

( 10143 ) : Fatal Error Zend OPcache can not allocate buffer for interned strings

Thank you very much if you can help me, I apologize for my English is not very good.


Means you don’t have enough RAM in relation to the settings in /etc/php.d/opcache.ini. How much RAM does the machine have?

For Apache vhosts, while it does emit this warning for RHEL/CentOS 7, it should still output the VHosts. However, try:
# httpd -t -DDUMP_VHOSTS

The fact you cannot reach api_v3/index.php?service=system would indicate something went wrong during
Please try to rerun it and paste the output.

But most importantly, need to address the RAM issue because plenty of things will fail due to that.

My memory RAM:
total used free shared buff/cache available Mem: 991 336 161 241 493 270 Swap: 0 0 0

httpd -t -DDUMP_VHOSTS
VirtualHost configuration:
*:443 (/etc/httpd/conf.d/ssl.conf:56)
*:80 (/etc/httpd/conf.d/zzzkaltura.conf:1) not exist, but there and run it again, it shows:

base-config completed successfully, if you ever want to re-configure your system (e.g. DB hostname change) run the following script:

Rm /opt/kaltura/app/base-config.lock



It is recommended that you 'do work using HTTPs. Would you like to continue anyway? [N / y]
Which port will listen on Vhost esta? [80]

Please select one of the following options [0]:
0. All web interfaces

  1. Kaltura Management Console [KMC], Hosted Apps, HTML5 lib and ClipApp
  2. KAC - Kaltura Admin Console
    Enabling Apache config - apps.conf
    Enabling Apache config - var.conf
    Enabling Apache config - admin.conf

Kaltura install file written answer to /tmp/kaltura_27_07_09_14.ans - Please save it!
This file can be used answers to silently re-install-install esta machine or deploy other hosts in your cluster.

Redirecting to / bin / systemctl restart httpd.service
Note: Forwarding request to ‘systemctl enable httpd.service’.
Note: Forwarding request to ‘systemctl enable memcached.service’.
Redirecting to / bin / systemctl restart memcached.service
Restarting Kaltura-monit (via systemctl): [OK]

It is possible that the incident is by memory , but I’ve done before one isntalación with 1 GB of RAM. However subire RAM, which are the minimum requirements for Kaltura ?

I’m unable to access my API Page as well. I tried to find the version in my history and went to which is also 404’d. I notice it exists on now, but I don’t know how or why the index.php one was in my history. When I try to go to it in the admin console I get the Not FoundThe requested URL /api_v3/testme/client-libs.php was not found on this server.

I see a test console here as well that can make the calls, but it’s small box is very frustrating: /admin_console/index.php/index/testme

Either way, looking at my config nothing seems immediately wrong. I’ll keep investigating though.

EDIT: Yeah even the links to the V3 console on the API test console knowledge page goes to the 404’d one:

Apparently I have solved as follows :

  1. I did a yum clean all
  2. I removed everything related to Kaltura yum remove '* * Kaltura ’
  3. Delete the / opt / Kaltura
  4. Add the repository again
  5. I returned to follow the installation guide .

This worked for me