SOLVED: Fatal error: Uncaught exception 'Zend_Config_Exception' with message 'Section 'media' cannot be found in /opt/kaltura/app/cache//batch/config.ini

I keep seeing this output from kaltlog:

2016-12-02 11:57:10 [0.000000] [1188617421] [1] [BATCH] [KSchedulerConfig->load] NOTICE: loading configuration /opt/kaltura/app/configurations/batch at 1480669746
PHP Fatal error: Uncaught exception ‘Zend_Config_Exception’ with message ‘Section ‘media’ cannot be found in /opt/kaltura/app/cache//batch/config.ini’ in /opt/kaltura/app/vendor/ZendFramework/library/Zend/Config/Ini.php:150
Stack trace:
#0 /opt/kaltura/app/batch/scheduler/KSchedulerConfig.class.php(59): Zend_Config_Ini->__construct(’/opt/kaltura/ap…’, ‘media’, true)

[2016-12-02 12:00:31]exception ‘Exception’ with message ‘Configuration file [/opt/kaltura/app/configurations/sphinx/populate/media.ini] not found.’ in /opt/kaltura/app/infra/log/KalturaLog.php:83
Stack trace:
#0 /opt/kaltura/app/plugins/sphinx_search/scripts/populateFromLog.php(36): KalturaLog::err(‘Configuration f…’)

What are the ramifications? Solution(s)?

Hello @merp,

You have multiple issues here. One has to do with the batch daemon being misconfigured and another with Sphinx.
To fix them, more info is needed:

  • Is this a deb or RPM based installation?
  • Is this a cluster or an all in one machine?

Also, from the errors in the log it seems both issues may stem from you changing your hostname post the Kaltura configuration phase, is that the case?

Greetings @jess
Sorry I forgot to include the same information from my previous posting (same system).
CentOS 7. The same system as detailed here: SOLVED: Fresh Install Kaltura CE 12.5.0 on Centos 7, Admin Console Login fails "Invalid credentials provided"

All on one server. Following the instructions from

The hostname should have been changed before the install, but it is possible that human error may have crept in right after the ISP setup the server, and configuring the server, during the preparation for Kaltura, and might have changed the hostname at inappropriate stage.
Just in case that was the case, should I re-run /opt/kaltura/bin/ ? Or do I need to wipe out Kaltura and DB, and reinstall Kaltura and DB fresh? Or is there a more elegant solution?


Hello @merp,

No need to drop the entire DB, you can simply re-run /opt/kaltura/bin/ providing the new hostname and SERVICE URL as inputs. It will correct both the batch and Sphinx configuration files and restart the daemons and you should then have a functional system.
In the DB, the only place where the hostname is stored that is of importance is the kaltura.delivery_profile table so do make sure that the host_name and url columns point to the correct hostname.

Okay, that went well. It also fixed a problem where the video uploads of new content from a publisher were stuck in “converting” mode. Now they just automatically work.
Many thanks again!
Our testing/learning continues.

Hi @merp,

The video ingestion is handled by the batch daemon, so indeed, if the daemon is not running, videos will not be converted:)
Glad to hear we’re good now.

1 Like