Reconfigure Kaltura VOD domain


I`m trying to reconfigure Kaltura instance for external access via domain.
Everything is ok without the playing. I configured kaltura for “kaltura.local” domain via, but KMC still uses ‘localhost’ urls for streaming.

Is here any way to repair this ?


Yes, see:

In addition, when changing the CDN hostname, the kaltura.delivery_profile table must be updated.

# mysql -h$DB1_HOST -u$DB1_USER -p$DB1_PASS

mysql> select id,name,url,host_name from delivery_profile;

Then use update statements to reset the url and hostname.

Ok! It works, thank you :slightly_smiling:

I have next question. I configured it as You suggested but still have problem with KMC urls.
After Publisher “Manage” action clicked Kaltura still redirects me to ‘localhost’ domain.

Is it configurable by configuration scripts or database ?


This is taken from /opt/kaltura/app/configurations/admin.ini
the settings.serviceUrl directive.

I believe you did not rerun the config scripts as explained in the page I linked to, however, otherwise, it would have changed.
Nonetheless, you can change it manually and reload your apache. However, there are multiple places to change which is why rerunning the config scripts is a better option.

When I running I have only two questions:

  • It is recommended that you do work using HTTPs. Would you like to continue anyway?[N/y]
  • Which port will this Vhost listen on? [80]
  • Please select one of the following options [0]:

So there is no way to configure hosts…
And when I running after providing api host, nginx host and port I have error:

Nginx port to listen on [88]:
Reloading nginx:                                           [  OK  ]
Running DWH config...

base-config completed successfully, if you ever want to re-configure your system (e.g. change DB hostname) run the following script:
# rm /opt/kaltura/app/base-config.lock
# /opt/kaltura/bin/

ERROR: /opt/kaltura/bin/ failed:( You can re-run it when the issue is fixed.


Setup completed successfully!

To access your Kaltura tools visit:

I don`t know what I have to do next. :cry:

To change the hostname, running front-config is not enough.
If you are using an all in 1 instance, run and provide the new hostname and service URL whenever prompted.

You don’t need to rerun since that one does not need the service URL and has no UI facing implications.

Jess, I do this and it didn`t help me.

Sorry but that does not help me help you.
What do you mean by “it didn’t help me”? what exactly happened, what is currently the problem?

It didn`t help me with issue described in this post: Reconfigure Kaltura VOD domain

Did you check the current value in /opt/kaltura/app/configurations/admin.ini like I indicated?

[root@bb8bdc0a02fe bin]# cat /opt/kaltura/app/configurations/admin.ini | grep localhost
[root@bb8bdc0a02fe bin]#

Should I change this value manually?

Yes. And reload Apache.

1 Like

Ok, it works.

Thanks! :grin: