Preroll ad not working

Hi I am new to kaltura and am trying to play a preroll VAST flash ad before a video. However I have been unable to do so. I also tried the example at However, when I hit demo the ad does not play only the video plays. And I did not change the preroll ad url I tried with the url it already had. I also checked my browser plugins and flash is enabled. What could be the issue?


Can you provide access to your embed code? Also, use the browser’s dev tools and check for errors under the ‘Console’ and ‘Network’ tabs.

Thanks for your quick response. I am trying the sample on that link as is in the player itself. So I just went to that link and tried the demo on the player itself without making any changes in the customize tab. I have not even started embedding that code in my web page. I was experimenting with ads. So the link already has a preroll ad url I did not make any changes to that too. I just went to that link and tried to play the video. However, I could not see the ad playing - the video started directly. I tried this on Chrome Version 47.0.2526.35 beta (64-bit). Is there some issue with my browser? I also checked for flash plugin in chrome://plugins and it is enabled.

Can someone please help me out with this issue? I am still not able to get it working. Is there some issue with my browser version or flash settings?

ok so I was finally able to get the online player working. The issue was with my browser itself. However, when I embed the same code in my webpage it refuses to show the ad.

Here’s my code:

<script src="">
<div id="kaltura_player_1446533425" style="width:430px;height:330px;" itemprop="video" itemscope itemtype="" >
    <!-- Search engine metadata, based on -->
    <span itemprop="description" content="test folgers coffe"></span>
    <span itemprop="name" content="FolgersCoffee_mpeg"></span>
    <span itemprop="duration" content="60"></span>
    <span itemprop="thumbnailUrl" content=""></span>
    <span itemprop="width" content="430"></span>
    <span itemprop="height" content="330"></span>
        targetId: "kaltura_player_1446533425",
        wid: "_2027961",
        uiconf_id: "31364952",
        entry_id: "0_xxbd4nt8",
        flashvars: {
            "vast": {
                "prerollUrl" : "[referrer_url]&description_url=[description_url]&correlator=[timestamp]",
                "numPreroll" : "1",
                "preSequence" : "1",
                "htmlCompanions" : "testCompanion:300:250;testLongCompanion:728:90;",
                "timeout" : "4",
                "storeSession" : false,
                "skipOffset" : "5",
                "unescapeAdUrls" : false
            "skipBtn": {
                "skipOffset" : "5",
                "label" : "Skip Ad"
            "noticeMessage": {
                "text" : "Advertisment {sequenceProxy.timeRemaining|timeFormat}"
            "adsOnReplay" : true

Am i missing something?

Looking at your embed, I see you are embedding the Flash player [KDP]. My first suggestion would be to create an HTML5 player using KMC->Studio->Universal Studio and use that in your embed.
If that does not work, use the browser’s devtools and check the “Network” and “Console” tabs for errors.

Ok please excuse me for my ignorance but how exactly did you guess its a flash player? And how do I create a HTML5 player? I do not see any such setting while creating a new player. Also, I checked the console there are no errors.

If you write click on the player in your embed, you will easily see it says:
kdp version: v3.9.9 and also "About Adobe Flash player…"
For HTML5: KMC->Studio->Universal Studio->create new player

Ok I tried playing the ad with a new player as you suggested. Still unable to see the ad. However, I am able to play the following ad with the kdp player:,728x90&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&correlator=[timestamp]. The only difference I see is in the tags in the ad xml file. The ad thats working has an Inline tag and the ad in the original example thats not working has Wrapper tag. Could that be the reason?