Player just spins in iOS 9.1


#6

We needed to reinstall Kaltura and we installed 11.2.1 and this problem has reappeared. Any help is appreciated.


#7

@steve_corey and myself working together.

We have kaltura 11.20 installed . Player has version 2.37.1 which is compatible with IOS. we are not able to play the video in ios 9.2.
FYI , we have reinstalled the kaltura and in earlier installation player was working fine in ios 9.2

Here is the configuration details are

{
“plugins”: {
“topBarContainer”: {
“plugin”: true
},
“controlBarContainer”: {
“plugin”: true,
“hover”: true
},
“scrubber”: {
“plugin”: true
},
“largePlayBtn”: {
“plugin”: true
},
“playHead”: {
“plugin”: true
},
“playPauseBtn”: {
“plugin”: true
},
“volumeControl”: {
“showSlider”: true,
“layout”: “horizontal”,
“pinVolumeBar”: false,
“accessibleControls”: false,
“accessibleVolumeChange”: 0.1,
“plugin”: true
},
“durationLabel”: {
“plugin”: true
},
“currentTimeLabel”: {
“plugin”: true
},
“keyboardShortcuts”: {
“volumePercentChange”: “0.1”,
“shortSeekTime”: “5”,
“longSeekTime”: “10”,
“volumeUpKey”: “38”,
“volumeDownKey”: “40”,
“togglePlaybackKey”: “32”,
“shortSeekBackKey”: “37”,
“shortSeekForwardKey”: “39”,
“openFullscreenKey”: “70”,
“closeFullscreenkey”: “27”,
“gotoBeginingKey”: “36”,
“gotoEndKey”: “35”,
“longSeekForwardKey”: “ctrl+39”,
“longSeekBackKey”: “ctrl+37”,
“percentageSeekKeys”: “49,50,51,52,53,54,55,56,57”,
“plugin”: true
},
“liveCore”: {
“plugin”: true
},
“liveStatus”: {
“plugin”: true
},
“liveBackBtn”: {
“plugin”: true
},
“fullScreenBtn”: {
“plugin”: true
},
“playersJsReceiver”: {
“plugin”: true
},
“watermark”: {
“cssClass”: “bottomRight”,
“img”: “https://kaltura.babyflix.net/content/babyflix.png”,
“href”: “http://www.babyflix.net”,
“hideTimeout”: 0,
“padding”: “15”,
“plugin”: true
},
“sourceSelector”: {
“switchOnResize”: false,
“simpleFormat”: true,
“displayMode”: “size”,
“plugin”: true
}
},
“uiVars”: [
{
“key”: “autoPlay”,
“value”: false,
“overrideFlashvar”: false
},
{
“key”: “autoMute”,
“value”: false,
“overrideFlashvar”: false
},
{
“key”: “enableTooltips”,
“value”: true,
“overrideFlashvar”: false
},
{
“key”: “adsOnReplay”,
“value”: true,
“overrideFlashvar”: false
},
{
“key”: “Kaltura.LeadWithHtml5”,
“value”: true,
“overrideFlashvar”: false
},
{
“key”: “imageDefaultDuration”,
“value”: 2,
“overrideFlashvar”: false
},
{
“key”: “Kaltura.UseAppleAdaptive”,
“value”: true,
“overrideFlashvar”: false
}
],
“layout”: {
“skin”: “kdark”
}
}

Please find the attached snapshot of uiconf of this player too
Please help


#8

Hi Amir, do you have any thoughts on why this would not work with the player upgraded? Here is a link to a video that just spins - https://kaltura.babyflix.net/tiny/vu6gp


#9

Hi Steve,
Seems that the HLS stream you are trying to play is not compatible with iOS Safari:
https://kaltura.babyflix.net/p/101/sp/10100/playManifest/entryId/0_fk0j79tj/flavorIds/0_twid2agc,0_ngt13kzu/format/applehttp/protocol/https/a.m3u8
Trying to play this natively on Safari fails and asks for an external plugin installation. I see this is a multi-flavour URL and trying to play any of the specific flavours works on Safari, for example: https://kaltura.babyflix.net/i/p/101/sp/10100/serveFlavor/entryId/0_fk0j79tj/v/2/flavorId/0_ngt13kzu/index_0_av.m3u8
I’m not an HLS expert so I can’t help much further. If you need additional assistance, perhaps Jess can refer you to the the right people (Eran K. maybe?)


#10

Jess, this problem has re-ocurred again after we have upgraded the player. Amir mentioned you might have a thought on what is happening here? Please see comment above. Any help is greatly appreciated.


#11

Hi Steve,

I don’t have any iOS devices to check with but the manifest looks like a valid one to me:
$ curl -v https://kaltura.babyflix.net/p/101/sp/10100/playManifest/entryId/0_fk0j79tj/flavorIds/0_twid2agc,0_ngt13kzu/format/applehttp/protocol/https/a.m3u8

#EXTM3U
#EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=520192,RESOLUTION=640x360
https://kaltura.babyflix.net/i/p/101/sp/10100/serveFlavor/entryId/0_fk0j79tj/v/2/flavorId/0_twid2agc/index_0_av.m3u8
#EXT-X-STREAM-INF:PROGRAM-ID=1,BANDWIDTH=720896,RESOLUTION=640x360
https://kaltura.babyflix.net/i/p/101/sp/10100/serveFlavor/entryId/0_fk0j79tj/v/2/flavorId/0_ngt13kzu/index_0_av.m3u8

You mentioned it happened since you upgraded the player, you can try to change the player version to the previous one to check if it is really related or not by doing:
mysql -ukaltura -p$DB1_PASS kaltura -h$DB1_HOST

mysql> select * from ui_conf where id=

And then update the html5_url column to use the prev version and see if that works.

If it does, then the issue is not in the backend, if it does not, then we know it is not related to the player version.
In that case, I suggest you start by opening the dev tools on your Safari and look for errors in the “console” and “network” tabs and in parallel, from the server’s shell run:
# kaltlog

and look for errors.

If an older player version does work, then we will need Amir’s help again.


#12

Also, I have seen cases in which the issue was actually due to SSL certificate problems, I even blogged about it once here:

Is it possible for you to try over HTTP just to see if this changes anything?


#13

I get it working by removing the “imageDefaultDuration” property from config


#14

Hm… http://player.kaltura.com/docs/api#mediaProxy.imageDefaultDuration
Amir, any thoughts on this one?

Also @abhimanyu_singh, just so we understand, did you add imageDefaultDuration recently and so it failed or does it work with the prev. player version but fails with current?

Thanks,


#15

@jess It was by default added when I created a new player , but as far I remember this property was not associated in prev. player. To me it seems, it is a bug . Player should be smart enough to judge when to play image and when to play a video. and why it has an issue with ios 9.1 and above and not in other version of ios . not on android and web.


#16

I can’t think of any correlation between imageDefaultDuration and the ability to play HLS streams. Setting this value doesn’t force using the image player, it just specifies how long to show the image when using the image player.
The link I send to the .m3u8 stream that doesn’t play on iOS9.2 Safari has no reference to the player anyhow.
I see that the original link (https://kaltura.babyflix.net/tiny/vu6gp) now works on iPhone iOS9.1. Did you change anything other than removing the imageDefaultDuration Flashvar from the UIConf?


#17

Has anyone resolved this? We have the same issue, and we are not on Kaltura 11.8 with player version 2.40. The loader just spins when i try to open video on iphone or ipad. The ipad allows me to choose the video quality (by default it’s on auto and it won’t play). If i chose one of the qualities on player through the ipad, the video starts to play. Here’s a link to the video:

http://162.244.80.109/index.php/extwidget/preview/partner_id/102/uiconf_id/23448236/entry_id/0_wwwsbct9/embed/auto?&flashvars[streamerType]=auto


#18

I just noticed that if i trim the video to 10 seconds, it starts to work. Any idea why?


#19

I have the same problem with 11.7.0 bit it seems related with remote storage and the hosts settings.

Anyway I solved using this workaround, confuring the video player with this flashvar:
Kaltura.UseAppleAdaptive=false

I hope this works also for you.

AML


#20

Thanks AML! It does work with Kaltura.UseAppleAdaptive=false, but the video buffers a lot. Is that an indication that the server is too slow? The video loads fine on desktops.


#21

I’m not sure but it could depends from flavor bitrate.
Try using a flavor with lower bitrate. Maybe you can find some flashvars to say to player which flavor to play.
Check the flashvars on player.Kaltura.com


#22

What was the syntax you used to add that variable to the configuration and around what line did you add it or between what lines of the configuration file did you add it? Can you please post a sample of the modified code?


From my domain,Kaltura host videos not working properly in IOS 10 version and Ipad devices
#23

Hi,

you can add this UI variable directly in KMC / Studio, please see this screenshot:


#24

@amletoguerra

Thank you for the help this resolved the issue for me as well. However, I do not have any lags as previousely described. I will update if there are any other issues but it is working for me now.


#25

I have the same problem with 11.17.

Indeed, by the following set, I was able to play the video in ios.

“uiVars”: [
{
“key”: “Kaltura.UseAppleAdaptive”,
“value”: false,
“overrideFlashvar”: false
}
]

In this case, it is delivered by [HLS] in ios? Or it is delivered in [HTTP Progressive Download] in ios?