KMC keep saying "You must have flash installed. click here to download"

I just installed Kaltura 11.2.0 on CentOS 6.7.

The installation was working well, but the problem is when I access to KMC is keep display “You must have flash installed. click here to download”, but I can access to Admin Console as normal.

This CentOS was installed on my local testing VM. And I already installed the latest version of Adobe flash. Can anybody help me with this? Because I’m very new with this thing.

Thank you

Turn out that I found the solution, after re-run and set the correct host name.


I’ve tried to rerum the the with the correct host name, and I am still getting the same error. Do you have any recommendations for where I went wrong? I installed the latest version of Kaltura.


You need to make sure the hostname/service URL you provide during the configure phase is accessible from both the server itself and from any outside client you intend to use the admin I/Fs or playback from.
My guess is you provided a hostname/service URL that is NOT resolvable from the machine where you make the request from.
This can easily be checked by opening your browser’s dev tools and looking at the requests made in the “Network” tab, then making sure the host used is resolvable.

I can ping the host outside the container and inside the container. Please advise.

the link to my site is

The issue is with these two:

Obviously, c6c18eb4180c is the container’s ID, also used as the hostname by default.
You need to check where that’s set under /opt/kaltura/app/configurations

Also, check the kaltura.delivery_profile DB table. This has nothing to do with loading the KMC but if the host defined there is wrong, playback will fail.