KMC Errors - Please Help!

After sucessfully logging into kmc, I’m presented with the following error after clicking on each section tabs

KMC.mxml, Module load failed: Error #2036

Can somebody tell me what might be causing this? - the server has reciently been rebooted (could this be service related (a service hasn’t restarted) or would this be something else?

Many Thanks


First, just to make sure, you are logging into KMC with a partner you created in the admin console and not with the admin console credentials, correct?
Next, best way to start debugging it would be to run:
# kaltlog
from the server’s shell while making the request and look at the output. Then go to the actual log where the error occurs and look at the lines leading to the error.
Feel free to paste the log entries here so we can further help you.

Hi Jess,

Thanks for the quick feedback - I’ve kind of fixed it
Using Firefox Firebug, I noticed that it was falling over in 2 places.

The process Get kmc.swf is looking for


However the server only has


I’ve not made any updates so I’.m rather confused as to how the folder name has increased by 1 yet the config is still looking for a different folder.

As a quick fix, I’ve copied the v5.39.9 folder and renamed to v5.39.8

Also a simular thing has happened to the studio folder

Again this is looking for studio.ini in the following location


Which was missing the file, however the was a second foder in the same location


Which did have the .ini file, so again i copied the file into the v2.0.0 folder

Nothing has been updated since the install, but the server has been rebooted, is there any behind the scene updates that occur automatically?

Also instead of duplicating folders / files, which config files would i need to update to point to the newer folders?

Many Thanks


My guess is you did not run the reconfigure scripts post upgrading the RPM/deb packages… did you?

Hi Jess,

This has never been updated as far as I’m aware, this was a clean install of 10.19.0 - we hired a freelancer to install it as we were having numerous issues with the SSL install and we didn’t have the Linux knowledge to fix all the SSL issues we kept experiencing during the setup process.

I’ve been away for the past 2 weeks, but everything worked prior to that (the server was rebooted whilst I was away, but as far as i know nothing has changed).

So are you saying that we should run

aptitude update

aptitude install ~Nkaltura

dpkg-reconfigure kaltura-batch

dpkg-reconfigure kaltura-front

and this will fix the issue?

Many Thanks


Its possible that your server is configured to automatically update packages upon init…
In any event, just run the following in that order:
# aptitude update
# aptitude install ~Nkaltura
# dpkg-reconfigure kaltura-base
# dpkg-reconfigure kaltura-front
# dpkg-reconfigure kaltura-batch

And you should be good. debconf will remember the answers from your last run, unless something changed, there is no need to touch the default values shown to you during the reconfig stage.

Hi I’ve run the first command

aptitude update

and recieved the following:-

-bash: aptitude: command not found

should i continue?, sorry I just want to check as I don’t want to mess things up

Many Thanks


That means that aptitude is not installed on your machine, only apt-get.
You can just replace the command ‘aptitude’ with ‘apt-get’ but I advise you to install aptitude with:
# apt-get install aptitude
both tools can be used but aptitude has a better API and somewhat improved decision making algorithms.

Hi Jess,

Sorry about this, but i get the following

-bash: apt-get: command not found

I’m guessing this is also not installed

Many Thanks

What Linux distro are you using?
# lsb_release -a

Hi Jess

LSB Version: :base-4.0-amd64:base-4.0-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: RedHatEnterpriseServer
Description: Red Hat Enterprise Linux Server release 6.7 (Santiago)
Release: 6.7
Codename: Santiago

Many Thanks

Alright, the idea is the same but the commands are slightly different then.
You need to follow the other link I posted, i,e:

Hi Jess,

Please excuse the silly questions, but does that mean everything under the heading Upgrade Kaltura

I only ask as i don’t want to run something that may potentially stop the server from working, and since this was originally setup by a third party, i just want to be sure that any actions i take are the correct ones.

Many Thanks

Yes, all these commands:

yum clean all
yum update kaltura-release
yum clean all
yum update “kaltura

Then follow the on-screen instructions (in case any further actions required). Once the upgrade completes, please run:


Hi Jess,

Thanks for this. I think I’ll go back to the third party and ask them to go through the update process.

Do you know is there a way to switch off auto updating? (I checked and the original install was 10.19.0 and it’s now 10.21.0 so this has definately auto updated)

Many Thanks

Hello @PIBelton,

This being Linux there are multiple ways of doing everything, including auto updates. It can be done by adding a line to /etc/rc.local, by adding a cron job and many many other ways, including Therefore, you should consult the people who setup the server.

In general, I’d recommend against auto updates on Prod. servers. Instead, you can have the machine email you when new updates are pending so you can decide what you want to do. Ideally, what you want to do is test them on a test ENV first:)