Kaltura server CE Installation ERROR: No site found matching zzzkaltura*!

Hi everyone, we’re installing Katura server CE following the instructions found at Github repository

With the following configuration:
Unbuntu 16.04 xenial
Apache 2 server
Mysql 5.5
Kaltura CE edition (downloaded on July 3rd, 2019)

We also tried Mysql 8.0.16, but it returned “ERROR 1054 (42S22): Unknown column ‘password’ in ‘field list’”. As we couldn’t solve that error (https://stackoverflow.com/questions/30692812/mysql-user-db-does-not-have-password-columns-installing-mysql-on-osx) we went back to Mysql 5.5.

We used install_kaltura_all_in_1.sh

When we advanced to “Configuring kaltura-front” purple screens, after we provided the data of “Your kaltura Service URL” screen, we received the following error:
ERROR: No site found matching zzzkaltura*!
Enabling site zzzkaltura.ssl.
To active the new configuration, you need to run:
service apache2 reload
Enabling site apps
(this message repeats 3 times)

As we couldn’t find any configuration settings help on the github instructions, we used both:

Finally when we arrived to the purple screen labeled “Configuring kaltura-db” it says:
Failed to connect to DB. Please check your setup and then run dpkg-reconfigure kaltura-db. Choose YES to remove existing DB or NO in order to keep it for debugging purposes.

When we run dpkg-reconfigure kaltura-db it returns:
dpkg: error processing package kaltura-db (–configure)
subprocess installed post-installation script returned error exit status 6

You can see the installation captured video here:

We tried multiple times, but the result is always the same: Kaltura is installed and we can access it through a web browser, but it doesn’t allow us to enter the admin

Any help or ideas will be welcome

Thanx in advance

Hello @jaguardigital,

What MySQL version are you currently working against (must be no higher than 5.6 and 5.5 is the recommended one as with 5.6, you must disable strict mode).
Assuming 5.5., what’s the output for:

mysql> select user,password, host from mysql.user;

You can mask the passwd hashes in your response here but the point is to make certain you have no records with no user and passwd set (what’s called anonymous users). If you do, that’s the reason for the failure and you should run mysql_secure_installation as per the instructions here: https://github.com/kaltura/platform-install-packages/blob/Orion-15.3.0/doc/install-percona-deb.md

Hi Jess

This is the result of running the command mysql> select user,password, host from mysql.user;

It may be important to notice that we’re running Ubuntu 16.04 under Virtual Box for testing purposes in order to upload the resultant image to a Digital Ocean server.

Thanks for your help

Just in case, this is the error we received when we tried to configure the database during the installation

Hi @jaguardigital,

So, clearly, the postinst code for kaltura-db (/var/lib/dpkg/info/kaltura-db.postinst) failed to connect to your MySQL DB. There are many possible reasons for it (wrong credentials, FW rules, etc). Start by ensuring you’ve input the correct credentials for the MySQL super user and that you’re able to connect to the server using the mysql CLI client (if you look at the postinst code, you will see that’s what it does). You can edit /var/lib/dpkg/info/kaltura-db.postinst so that:

#!/bin/bash -


#!/bin/bash -x

and then run:

# apt install -f

This will cause BASH to output a lot of debug info, including all the mysql commands.

It finally worked, we followed the configuration settings in the link:

We used “localhost” in the following inputs
Analytics DB Hostname
default: localhost

DB Hostname
default: localhost

We previously changed both addresses to “” because the configuration settings in the github help told us to do that. When we returned those two values to “localhost”, it worked properly

Hope this works for anybody else, thanks for your help