Kaltura CE 13.13.0 released


#1

Hello all,

The latest version is now available.

kaltura-base (13.13.0) changelog:

kaltura-html5lib (2.66) changelog:

  • FEV-139 - [IVQ-Player] change apply/continue to select
  • FEV-112 - [IVQ] quiz in playlist - answers below text
  • FEV-113 - [IVQ] quiz in playlist - intro page
  • FEV-147 - Hide “admin” slides/chapters/player mode in preview mode
  • KMS-15631 - [IVQ] change to the Submit button
  • FEC-7834 - CLONE - Unable to change media on Chromecast while casting media
  • SUP-13105 - KCP - Caption image is saved on the Player.
  • FEC-7797 - Adding VPAID INSECURE mode
  • FEC-7657 - PWA - Android- [360 Playback] - Video fails to play and only audio is audible with a blank screen during 360* video playback(Refer Steps)
  • SUP-13081 - Playlist secure embed not working when include in layout = false
  • FEC-7835 - CLONE - Cast fail when using Chrome browser cast button
  • SUP-13403 - KCP - Subtitle set to ‘English’ after subtitle option setting
  • FEC-7878 - Remove support check for Windows phone on mobile skin
  • SUP-13171 - Player is not displaying VPAID ads in a correct manner
  • FEC-7885 - KAnlony sends empty referrer in iframe embed
  • FEC-7891 - CLONE - [Chrome Cast] - Time in scrubber bar at TV displayed unclear
  • FEV-165 - Creator user does not see chapters when in preview mode
  • fix: initial captions to CC
  • fix: exception when changing from local to remote CC playback
  • fix: reset all CC state flags on media change
  • add quality watcher for dash streams
  • fix: detect if kAnalony is active
  • feat(chromecast): cast via chrome browser button (#3720)
  • add uiconf_id param to chromecast (#3721)
  • fix(chromecast): proxyData getter (#3719)
  • fix youbora error code handler
  • CC - Fix autoplay on live (#3725)

kaltura-kmc (5.43.12) changelog:

  • PLAT-8413 - add two types of Chinese subtitles
  • Ver bounce of HTML5 player to v2.66

To upgrade, please follow:

RPM based:

Deb based:

Or, if running a cluster:



#2

kaltura-base upgrade on ubuntu 16 fails with:

ERROR 1046 (3D000) at line 1: No database selected


kaltura-base.postinst FAILED with: 24998 on line 64

solved this by adding use $DB1_NAME; to the query on line 64

After solving this it throws error on line 65 -P requires an argument. The $DB1_PORT variable was not included in /etc/kaltura.d/system.ini in the previous version, I suppose and this was the cause of it.
Also I had to hardcode the super user and password in the postinstall script as it was not asking for them as usual. After this the postinstall script executed successfully.
Then I had to rm -f /etc/apache2/sites-enabled/zzzkaltura.ssl.conf because of:

Feb 14 21:15:12 streamhub1.go.ro apache2[25457]: AH00526: Syntax error on line 19 of /etc/apache2/sites-enabled/zzzkaltura.ssl.conf:
Feb 14 21:15:12 streamhub1.go.ro apache2[25457]: SSLCertificateFile: file '/etc/apache2/@SSL_CERTIFICATE_FILE@' does not exist or is empty
Feb 14 21:15:12 streamhub1.go.ro apache2[25457]: Action 'configtest' failed.
Feb 14 21:15:12 streamhub1.go.ro apache2[25457]: The Apache error log may have more information.
Feb 14 21:15:12 streamhub1.go.ro systemd[1]: apache2.service: Control process exited, code=exited status=1
Feb 14 21:15:13 streamhub1.go.ro systemd[1]: Failed to start LSB: Apache2 web server.
Feb 14 21:15:13 streamhub1.go.ro systemd[1]: apache2.service: Unit entered failed state.
Feb 14 21:15:13 streamhub1.go.ro systemd[1]: apache2.service: Failed with result 'exit-code'.

Only then the kaltura-base install from aptitude was successful and I was able to reconfigure with dpkg-reconfigure.

For kaltura-nginx I had to apt install libzvbi* because the nginx service was searching for the lib and failed to start.


#3

Hi @mediasync,

All the DB1_.* ENV vars and other important vars the postinst scripts use are defined in /etc/kaltura.d/system.ini which is a symlink to /opt/kaltura/app/configurations/system.ini.
Is it possible you deleted it by mistake?

It would surely exist now since you’ve reconfigured the kaltura-base package successfully [which triggers the exec of /var/lib/dpkg/info/kaltura-base.postinst] but if it didn’t exist when you tried to upgrade the reason for failure is obvious.


#4

the file existed but it was not including the DB1_PORT var.
the problem started from the fact that the mysql cli was not reading the db name at the end of the command, although the var contained the correct value.
These are the packages I have related to mysql:

# dpkg -l|grep mysql
ii  libdbd-mysql-perl                   4.033-1ubuntu0.1                           amd64        Perl5 database interface to the MySQL database
ii  libmysqlclient20:amd64              5.7.21-0ubuntu0.16.04.1                    amd64        MySQL database client library
ii  mysql-common                        5.7.21-0ubuntu0.16.04.1                    all          MySQL database common files, e.g. /etc/mysql/my.cnf
ii  percona-server-common-5.5           5.5.59-rel38.11-1.xenial                   amd64        Percona Server database common files (e.g. /etc/mysql/my.cnf)
ii  php-mysql                           1:7.0+35ubuntu6                            all          MySQL module for PHP [default]
ii  php7.0-mysql                        7.0.25-0ubuntu0.16.04.1                    amd64        MySQL module for PHP

#5

This topic was automatically closed after 8 days. New replies are no longer allowed.