Kaltura All-in-One Video Plugin for WordPress install problem


I am trying to install the “Kaltura All-in-One Video Plugin for WordPress” plugin, available here: https://wordpress.org/plugins/all-in-one-video-pack/. I tried with the latest version of wordpress, 4.9.1, as well with older version stated on the plugin page to be tested with, 4.6.9. I also tried randomly with an older version of wordpress, 4.5.12, but the same problem occurs. I tried to search these forums, but the information is scarce and outdated. Every time I used the latest version of the plugin, 2.7.
So what happens with all the versions I enumerated above is that after installing the plugin and clicking activate, a message is displayed all over the wordpress backend, stating: To complete the All in One Video Pack installation, you must get a Partner ID. Clicking on “you must get a Partner ID” loads a page with the wordpress menu on the left and no other content. So the configuration part of the installation is stuck at this point. I’ve red about an ini file for the plugin but I could not find it, I suppose is deprecated.
Please help.

Dan Ionescu


Hi @mediasync, thanks for reaching out.
The plugin for wordpress is not managed on the player level so I’m afraid I cannot add any insights regarding it.
I suggest you try the " Community Forums API and App Developers Support"


@mediasync, after you installed and activated the plugin, did you also go to wp-admin/options-general.php?page=kaltura_options and set it up?
You are expected to input several parameters, partner ID is one of these.

If you input the wrong values, you can go to wp-admin/options-general.php?page=kaltura_options&partner_login=true which will allow you to correct the partner ID, email and passwd.


Hi Jess!

Sorry for the delay answering this.
Going to wp-admin/options-general.php?page=kaltura_options gives an empty page as I described in the initial post.
Going to wp-admin/options-general.php?page=kaltura_options&partner_login=true gives a form to login with the partner ID, email and password, but after I hit the Complete Installation button, again an empty page is displayed.
Is there anything I can do to debug this. Any help is apreciated.
Thank you,


Hi @mediasync,

A blank page means the request failed for some reason. Most likely, the PHP code erred and HTTP 500 was returned. You can easily verify that by opening the dev tools in your browser and checking for failed requests under the “Network” tab. While you’re at it, also look for errors in the “Console” tab.

In addition, to properly debug this [or any WP issue for what matter], please see the steps described here: https://codex.wordpress.org/Debugging_in_WordPress
Once you enable debugging and we have the error, we’ll be able to advance towards a resolution.


Hi @jess !

Thank you so much for your help.
I managed to enable debuging in WP and figured out that there were some php modules needed to be installed. It happens that the module makes use of php-xml and php-mcrypt (at least that’s how they are called in debian/ubuntu package management, aptitude). For everyone else reading/needing this I solved it by issuing the following as root:

apt-get install php-xml
apt-get install php-mcrypt
service apache2 reload

I still have some issues with the module not saving the advanced settings, but I think I should open another thread.

Thanks again. Regards,


Hi @mediasync,

Glad to hear we’re good. Feel free to post additional questions.

Happy videoing,