Kaltiran Community Edition 10.19.0 - Live HLS Stream not working

      System1: Centos 6.6 / Kalturak CE 10.19.0

System2: Centos 6.6 / Mistserver / Nimble etc (tested demo streams this
works fine, no issues what so ever, i add it to the built in test or
even any hls/hds player it works fine)

Scenario: I have finally installed kaltura without issue and its
working fine, i have also setup another server with cdn to deliver all
sorts of out puts. I want to add these links to kaltura and get the
player to support this live link and get stats from it, Also on a
schedule it plays videos uploaded!

Problem: when i add the url of the hls it dont load, the kaltural
player keeps looking and nothing! what i did was goto Uploads >>
Live Stream Entry > Sleeted Manual Stream URL’S from drop down, then
added the url ( but they player keeps looping, how do i get this started!

Solotions: Please help me get this sorted???

yes now it says media not found :frowning: please refer the attached

okay so what i have noticed is if i add the HLS url ((
to the HDS url field it give media not found (i did this to test it
out, i know i am not suppose to do that, checking all my options), but
if i add only HLS (( url and save it, the player keep loading with a continues loop.

You can only play HLS is you have a CDN that supports that protocol or by using the Kaltura vod-nginx-module [https://github.com/kaltura/nginx-vod-module] included in Kaltura CE in the kaltura-nginx package. I am not sure what is exactly… what machine is that?

That’s a fake ip! I have a cdn and it does support HLS RTMP and Dash but does not play on kaltura player but if I put it to any other player that has HLS supprt it works for example http://flashls.org any of the sample players plays the HLS i put from my cdn is the cdn with the HLS stream

jess, do i have to add this?


For Live streaming, you need to follow instructions here:

Kaltura Live streaming is implemented with the use of Wowza.

why do you need wowza when a cnd is providing the stream, all kaltura has to do is play the stream like any other live stream, i am not expecting kaltura to provide the stream just play the provided stream live is play other live stream.

and frankly why does it have a manual live stream like if you need to do all these chagers? whats the poit if having a place to add the url if it dont simply work!? is it just for show? as much as i appriciate your help and response, simply tell me, i wont waste anymore of my time!

whats the above hls placement for?


Not sure I understand your question.
Basically, the Live Mobile HLS stream URL field should contain a URL pointing to your live entry at the CDN, like:

If that does not work, please explain exactly what you’re seeing.

Also see:

Which explains the process.

@imran_sheriff - Kaltura CE can be used for various workflows including VOD (its specialty) and Live (rather new workflow). In Live, Kaltura CE relies on either having a Streaming Server integrated with it (that’s the media-server project mentioned, Wowza is currently best integrated) or by manually providing URLs to valid HDS or HLS streams (the “Manual Live Stream” options).
To effectively help you resolve your issue, please clarify your desired workflow: -
You have your own Live Stream URL for both HLS and HDS, and you’re trying to use Kaltura player to play your live stream. You don’t want to use Kaltura to provision the live stream for you, just play it through the Kaltura player.

If that’s so, indeed the correct method is to use the Manual Live Stream option.
As mentioned above, you can see an example here; http://knowledge.kaltura.com/configuring-live-streaming-kmc-account-using-bitgravity-account

This player below shows an example of using the Manual Live Stream option on the latest Kajam-11 branch:


It is using the following Level3 CDN HLS URL:


We recently got a similar report which also included log entries, enabling me to debug and fix the issue.
See here:

Also, made a pull request to fix it for future versions here:

Would like to know if that is the same issue as you were having.