Issue with batch server

I’ve installed a batch server, but when the server tries to convert a clip (ffmpeg) it fails

In the convert log I see this:

-i inFileName -c:v libx264 -subq 5 -qcomp 0.6 -qmin 10 -qmax 50 -qdiff 4 -coder 1 -refs 2 -vprofile main -force_key_frames __forceKeyframes__324_2.002002002002 -pix_fmt yuv420p -b:v 900k -s 640x480 -r 29.97 -g 60 -c:a libfdk_aac -b:a 64k -ar 44100 -ac 2 -map_chapters -1 -map_metadata -1 -f mp4 -flags +loop+mv4 -cmp 256 -partitions +parti4x4+partp8x8+partb8x8 -trellis 1 -refs 1 -me_range 16 -keyint_min 20 -sc_threshold 40 -i_qfactor 0.71 -bt 300k -maxrate 900k -bufsize 1200k -rc_eq ‘blurCplx^(1-qComp)’ -level 31 -async 1 -vsync 1 -threads 4 -y outFileName;FS

sh: FS: command not found

While on the main server the (where conversions are currently done) the “;FS” at the end doesn’t exist (and the fast start works after the ffmpeg)

Hi Ofer,

What version do you have installed? Also, does this happen with every conversion or just a specific one?


Hi Jess,

Version: 9.19.7
I think it always happen (I tried one entry, and it happened to all flavors this servers tried to convert)

Hi Ofer,

Does not happen for me. Can you please run the and check whether this works?

No it doesn’t. (the extract media fails)
The batch is 9.19.7 while the main is 9.18 , can it be the issue?
Is there a link for older versions (assuming I want to upgrade the server right now)

Yes, it could certainly be an issue.
I will be releasing 9.19.8 today, I would suggest you align all nodes to this version,

for now I just duplicated the main server, changed batch config, and stopped httpd

9.19.8 just released. Please upgrade following:

or, for a cluster: