Install fails with " failed:"

Have tried multiple times to install and keeps crashing when it goes to complete the sphinx integration.

Running Sphinx config…

base-config completed successfully, if you ever want to re-configure your system (e.g. change DB hostname) run the following script:
rm /opt/kaltura/app/base-config.lock

            Archving logs to /opt/kaltura/log/log_09_10_14_19_28.tar.gz...

ERROR: /opt/kaltura/bin/ failed:( You can re-run it when the issue is fixed.


Please run
# bash -x /opt/kaltura/bin/
And paste the output.

Thank you,

This URL will take you to the output.


Hi Bill,

The issue starts here:

  • /etc/init.d/kaltura-sphinx restart
    ++ my_trap_handler 62 34827

i.e the restart returns something other than 0.
Can you run:
# bash -x /etc/init.d/kaltura-sphinx restart

You should see this:
su kaltura -c '/opt/kaltura/sphinx/bin/searchd --config /opt/kaltura/app/configurations/sphinx/kaltura.conf

I imagine this will result in something other than 0.
Please then run this one manually from the shell and lets see what the output is.

BTW, what distribution are you using?

Using the most current from Yum. 9.19

  • . /etc/kaltura.d/system.ini
    ++ WEB_DIR=/opt/kaltura/web
    ++ LOG_DIR=/opt/kaltura/log
    ++ APP_DIR=/opt/kaltura/app
    ++ BASE_DIR=/opt/kaltura
    ++ PHP_BIN=/usr/bin/php
    ++ OS_KALTURA_USER=kaltura
    ++ DB1_HOST=
    ++ DB1_NAME=kaltura
    ++ DB1_USER=kaltura
    ++ DB1_PASS=PufQUT3wac3pGV9
    ++ DWH_HOST=
    ++ DWH_PORT=3306
    ++ DWH_USER=etl
    ++ DWH_PASS=PufQUT3wac3pGV9
    ++ DB1_PORT=3306
    ++ SUPER_USER=root
    ++ SUPER_USER_PASSWD=ualaue=42
    ++ RED5_HOST=kaltura
  • . /opt/kaltura/app/infra/scripts/functions.rc
    ++ TEXTDOMAIN=initscripts
    ++ umask 022
    ++ PATH=/sbin:/usr/sbin:/bin:/usr/bin
    ++ export PATH
    ++ ‘[’ -z ‘’ ‘]’
    ++ COLUMNS=80
    ++ CONSOLETYPE=pty
    ++ ‘[’ -z pty ‘]’
    ++ ‘[’ -f /etc/sysconfig/i18n -a -z ‘’ -a -z ‘’ ‘]’
    ++ . /etc/profile.d/
    ++ unset LANGSH_SOURCED
    ++ ‘[’ -z ‘’ ‘]’
    ++ ‘[’ -f /etc/sysconfig/init ‘]’
    ++ . /etc/sysconfig/init
    +++ BOOTUP=color
    +++ RES_COL=60
    +++ MOVE_TO_COL=‘echo -en \033[60G’
    +++ SETCOLOR_SUCCESS=‘echo -en \033[0;32m’
    +++ SETCOLOR_FAILURE=‘echo -en \033[0;31m’
    +++ SETCOLOR_WARNING=‘echo -en \033[0;33m’
    +++ SETCOLOR_NORMAL=‘echo -en \033[0;39m’
    +++ PROMPT=yes
    +++ AUTOSWAP=no
    +++ ACTIVE_CONSOLES=’/dev/tty[1-6]’
    +++ SINGLE=/sbin/sushell
    ++ ‘[’ pty = serial ‘]’
    ++ __sed_discard_ignored_files=’/(~|.bak|.orig|.rpmnew|.rpmorig|.rpmsave)$/d’
  • prog=searchd
  • config=/opt/kaltura/app/configurations/sphinx/kaltura.conf
  • exec=/opt/kaltura/sphinx/bin/searchd
  • pid_file=/opt/kaltura/sphinx/
  • case “$1” in
  • restart
  • stop
  • echo -n 'Stopping searchd: '
    Stopping searchd: + /opt/kaltura/sphinx/bin/searchd --config /opt/kaltura/app/configurations/sphinx/kaltura.conf --stopwait
    Sphinx 2.2.1-id64-dev (r4097)
    Copyright © 2001-2013, Andrew Aksyonoff
    Copyright © 2008-2013, Sphinx Technologies Inc (

using config file ‘/opt/kaltura/app/configurations/sphinx/kaltura.conf’…
FATAL: stop: pid file ‘/opt/kaltura/sphinx/’ does not exist or is not readable

  • retval=1

  • echo

  • ‘[’ 1 -eq 0 ‘]’

  • return 1

  • start

  • ‘[’ -x /opt/kaltura/sphinx/bin/searchd ‘]’

  • ‘[’ -f /opt/kaltura/app/configurations/sphinx/kaltura.conf ‘]’

  • echo -n 'Starting searchd: '
    Starting searchd: + su kaltura -c '/opt/kaltura/sphinx/bin/searchd --config /opt/kaltura/app/configurations/sphinx/kaltura.conf’
    This account is currently not available.

  • retval=1

  • echo

  • return 1

  • exit 1

Problem is here:

Starting searchd: + su kaltura -c '/opt/kaltura/sphinx/bin/searchd --config
This account is currently not available.

The ‘kaltura’ user should have /bin/sh as shell, like so:
kaltura:x:7373:7373:Kaltura server:/opt/kaltura:/bin/bash

From your output, it seems like either the kaltura user does not exist or it has no shell.

The user is created during kaltura-base’s preinstall like so:
# create user/group, and update permissions
groupadd -r kaltura -g7373 2>/dev/null || true
useradd -M -r -u7373 -d /opt/kaltura -s /bin/bash -c “Kaltura server” -g kaltura kaltura 2>/dev/null || true
getent group apache >/dev/null || groupadd -g 48 -r apache
getent passwd apache >/dev/null ||
useradd -r -u 48 -g apache -s /sbin/nologin
-d /var/www -c “Apache” apache
usermod -a -G kaltura apache

usermod -g kaltura kaltura 2>/dev/null || true

Do you have the user? have you perhaps manually changed its shell to /sbin/nologin?

Looks like I have a user, but different permissions than you list.


I did try to just connect to the kaltura database as the kaltura mysql user and kaltura did not exist, so I ran just the db_config, and got tables created, but ran into sphinx again:

CREATE USER kaltura;
CREATE DATABASE kaltura_sphinx_log;
CREATE DATABASE kalturadw_ds;
CREATE DATABASE kalturadw_bisources;
Checking connectivity to needed daemons…
Connectivity test passed:)
ERROR: Couldn’t connect to Sphinx with mysql -h127.0.0.1 -P9312.
Please check your setup and then run /opt/kaltura/bin/ again

Did not manually change, but I will reset to /bin/bash

What Linux distro are you using?
# cat /etc/issue
Also, after manually changing, does it work?

We are using: Red Hat Enterprise Linux Server release 6.5

Definitely got a lot farther in the process.

Still not able to login as an administrator, but just now getting a chance to look at the mysql tables and users created.

Jess, thanks for the assistance.

Once I removed my MySQL server, and started clean again the user permissions did the trick.


Sure Bill. Happy to assist and do let me know should you need anything.

Figures I would next bump into an Apache config.

After logging into the kmc, I am dropped at:

Did not want to use secure so unsure why it’s going there, also made sure that any extra .conf files were disabled.

So should just be using: httpd.conf, the xymon-apache.conf, and zzzkaltura.conf.


Hi Bill,

Are you able to login to admin console? Also, did the install complete successfully? did you get the welcome message in the end and the welcome email?
Finally, what does:
# apachectl -t -DDUMP_VHOSTS

Jess, all is working now. But of course now I want to use it with SSL.

I have removed, and am working through the re-install questions. Only problem is right now I never get a chance to answer the question if I want to use SSL. It just automatically says:

It is recommended that you do work using HTTPs. Would you like to continue anyway?[N/y]

So I’m trying to determine which lock file I’m missing to get to answer Y first to the fact that I want to use SSL now.


Found a another post where you said to make sure the service URL was the 443 port. Once used that in a re-install I got the questions I needed.

Great, Bill.
Are we good now?

I wish. Now I have the https starting, but when I click on the icon for the admin console I get: (error code: API:-1)

Just starting to look at it.

Now I get a Console, but it fails to populate, so looking at apache error log:

[Wed Oct 15 23:45:14 2014] [error] [client] PHP Warning:  mkdir(): Permission denied in /opt/kaltura/app/vendor/symfony/log/sfLogger/sfFileLogger.class.php on line 41
[Wed Oct 15 23:45:14 2014] [error] [client] Unable to open the log file “/opt/kaltura/app/alpha/log/p_-1.log” for writing