Install config failed on first time install

Hi, this is my first experience with Kaltura, when i ran the config it failed, see below. Not sure why its even asking me for ssl as im doing a non ssl install.

This is on a linux CentOS 6 64bit with apache 2.2 and PHP and MySQL already installed. I did run thru the MySQL security option as required. I am also running webmin and virtualmin

Checking MySQL version…
mysql: [Warning] Using a password on the command line interface can be insecure.
Ver 5.7.15 found compatible
mysql: [Warning] Using a password on the command line interface can be insecure.
ERROR 1054 (42S22) at line 1: Unknown column ‘password’ in ‘field list’ FAILED with: 1 on line 337

Archving logs to /opt/kaltura/log/log_12_09_16_09_40.tar.gz…
cp: cannot stat `/opt/kaltura/log/*log’: No such file or directory
tar: *log: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors
curl: (60) Peer certificate cannot be authenticated with known CA certificates
More details here:

curl performs SSL certificate verification by default, using a "bundle"
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn’t adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you’d like to turn off curl’s verification of the certificate, use
the -k (or --insecure) option.
ERROR: could not find /etc/kaltura.d/system.ini so, exiting…

I have noticed that the system.ini file was permission 0000 and it was empty, so i deleted it and recreated a new one with owner root:root and permission 644

I will also try to remove the curl cert check if i can and retry running the config again.

UPDATE: nope same result. Well looks like im not going to be able to install this without some help.


Your problem starts way before the SSL config, I’m afraid. It starts here:
ERROR 1054 (42S22) at line 1: Unknown column ‘password’ in ‘field list’

You can see a long explanation here:

Long story short:
In MySQL 5.7, the password field in mysql.user table field was removed, now the field name is ‘authentication_string’.

I take it your MySQL package is not the one included in the official CentOS 6 repo, since that is of version 5.1.73.

Nonetheless, if you wish to use MySQL 5.7.15, I’m willing to help you and patch the install scripts accordingly so others can benefit from it.
Start by changing:
/opt/kaltura/bin/, line 337, instead of:
echo "update mysql.user set password=PASSWORD('$DB1_PASS') WHERE user='kaltura';flush PRIVILEGES" | mysql -h$DB1_HOST -P$DB1_PORT -u$SUPER_USER -p$SUPER_USER_PASSWD mysql

echo "update mysql.user set authentication_string=PASSWORD('$DB1_PASS') WHERE user='kaltura';flush PRIVILEGES" | mysql -h$DB1_HOST -P$DB1_PORT -u$SUPER_USER -p$SUPER_USER_PASSWD mysql

Then, remove the broken symlink to /etc/kaltura.d/system.ini and re-run
When it comes to the part, if you don’t wish to use SSL, note that it will ask:

Is your Apache working with SSL?[Y/n]

Answer 'n’
it will then warn you:

It is recommended that you do work using HTTPs. Would you like to continue anyway?[N/y]

Answer ‘y’ to continue.

1 Like

Hi jess, thanks so much for the reply and the assistance. You are correct the MySQL is an post install. The server came with the OS but nothing else and i did not want the 5.3 verson of MySQL that was in yum repos so i manually installed MySql 5.7

So sorry for the late return reply as i was up all night and had to get some rest. I will have a look and get back to you asap… Thanks again… very much appreciated :slight_smile:

OK the config appears to have finished this time. I could not find any symlink to the system.ini file so i left the empty one i created in place so at least it could find it this time. The MySQL patch for the config file worked great and i added a comment in the file for reference. I was also notified by webmin that there was an update to kaltura so i installed that as well.

But here is the output from the config file run.

Checking MySQL version…
mysql: [Warning] Using a password on the command line interface can be insecure.
Ver 5.7.15 found compatible
mysql: [Warning] Using a password on the command line interface can be insecure.

Kaltura install answer file written to /tmp/kaltura_12_09_18_46.ans - Please save it!
This answers file can be used to silently-install re-install this machine or deploy other hosts in your cluster.

Generating client libs…
This can take a few minutes to complete, see log at /opt/kaltura/log/generate.php.log.

    Configuration of 12.0.0 finished successfully!

and then the curl ssl warning but thats ok if i decide to do ssl later i can add it.

Thanks again so very much :slight_smile:

Now i just have to figure out how to use this and get it installed at the domain level :slight_smile: checking documentation now :wink: