Getting Black Screen on Add new media

I have installed Kaltura Video Platform - Community Edition v5.0.0 ( and Installed the drupal7( in same server with different port. In Drupal configuration i got all in green signal with successful message. I’m able to use the sample video in drupal. But when i’m trying to upload video i’m getting black screen “uploader swf is not loading”.


CE 5.0 is obsolete and no longer supported.
Please see install docs for 9 here:

Thank you,

Thats fine Jess. Can you help me what will be issue.

Not sure I understand…
Did you install 9 or not? If so, what is the current issue?

Current issue : In Add media popup “add new” swf was coming black screen at Drupal. Im unable to upload video via Drupal module.


As I wrote, we no longer support CE 5. It is about 3.5 years old.
Please install 9.

Jess… After upgrade also still facing same problem
_x and below is the flash not loaded i have inspected in firebug and got it



What is the output of:
# rpm -qa "kaltura"

I tried your command in putty. I got “The program ‘rpm’ is currently not installed.” So i hv installed the rpm using “apt -get rpm install”. successfully installed. Then i hv restarted the apache. After that i hv tried your command again i didn’t get any response.

You are using Debian/Ubuntu whereas the Kaltura platform is currently only supported on RHEL/CentOS 64bit.
Please see here: