File conversion does not work in 11.8.0 Kaltura

Hello, I installed the new Kaltura version 11.8.0 in my Centos 6.7 (mysql and php standard installed with yum) and unfortunately the conversion (transcoding) for all uploaded video (after the first one) is very very slow if compared with all previous version version of Kaltura from 10.16.0 and higher (I tried all version from 10.16.0 and higher).
I use the standard encoding profiles provided by Kaltura. I also tried to disable all encoding profiles other than source, basic / small, SD / Large, but even so some flavor remain suspended and never ending, except by errors.

I tried to reconfigure batch with /opt/kaltura/bin/ but it did not work.
I can not figure out how to solve.

I have tried installing 3 times with Kaltura 11.8.0 VM (centos 6.7) and real servers (4core and 32GB ram)

this is my kaltlog:

any suggestion is appreciated


Looking at your log, it seems the DB population phase did not complete successfully.
Start by running:
and rerunning the script.

Make sure this completes successfully and without any errors and if there are errors, post them here.


Hi Jess,

thanks for your support!

I dropped the db and tried to reconfigure with the script, but it fails as showed below:

[root@kaltura ~]# /opt/kaltura/bin/
Running base config…

Welcome to Kaltura Server 11.8.0 post install setup.

To keep up with the bi-weekly Kaltura releases, and stay up to date with
the latest news, security and bug updates, and connect with the global
Kaltura community - sign up for our regular Kaltura Community updates.
Please enter your email to sign up, or enter NO to pass.

In order to finalize the system configuration, please input the following:

CDN hostname [kaltura.local]:

The host will be accessed over http(s). In case your CDN operates on a non-default port, please input CDNHOST:PORT.

Apache virtual hostname [kaltura.local]
(Must be accessible from both inside the machine and from any clients / browsers that will use Kaltura):

Vhost port to listen on [80]:
range of ip addresses belonging to internal kaltura servers []:
The range is used when checking service actions permissions and allowing to access certain services without KS from the internal servers.
The default is only good for testing, on a production ENV you should adjust according to your network.

DB port [3306]:
MySQL super user [only for install, default root]: root
Analytics DB hostname []:
Analytics DB port [3306]:
Sphinx hostname []:
Secondary Sphinx hostname [leave empty if none]:
Your Kaltura Service URL [http://kaltura.local]
(Base URL where the Kaltura API and Apps will be accessed from - this would be your Load Balancer URL on a cluster or same as your virtual host in an all-in-one Kaltura server - Must be accessible from both inside the machine and from any clients / browsers that will use Kaltura):

VOD packager hostname [kaltura.local]:
VOD packager port to listen on [88]:
Admin user login password (must be minimum 8 chars and include at least one of each: upper-case, lower-case, number and a special character):
Confirm passwd:
Your time zone [see], or press enter for [Europe/Rome]:
Your Kaltura install name (this name will show as the From field in emails sent by the system) [Kaltura Video Platform]:DigitalBees OVP
Your website Contact Us URL []:
Your ‘Contact us’ phone number [+1 800 871 5224]:+39 02 525051
Checking MySQL version…
Ver 5.1.73 found compatible

Kaltura install answer file written to /tmp/kaltura_20_02_23_42.ans - Please save it!
This answers file can be used to silently-install re-install this machine or deploy other hosts in your cluster.

sed: espressione -e #47, carattere 40: opzione di `s’ sconosciuta FAILED with: 13133 on line 367

Archving logs to /opt/kaltura/log/log_20_02_16_23_42.tar.gz…
ERROR: /opt/kaltura/bin/ failed:( You can re-run it when the issue is fixed.

Hi @amletoguerra,

The problem is when the sed utility is trying to replace the tokens in the config template files with the values you inputted.
Please edit /opt/kaltura/bin/ and add:
set -x
just before the sed line, that is, before line 367 and then
set +x
right after.
This will output quite a bit of debug info, copy it and email me at, along with /tmp/kaltura_20_02_23_42.ans and I’ll help you understand why the sed is failing. It is due to some problematic character…

Hi Jess,

I reply in the thread after provided you the information by email.

I can confirm that the problem to script has happened only once, when I tried to run configure-base as suggested me.

Because I am not to reproduce that error, but it seems to me not relevant for the transcoding issue, I sent you everything you required me by email, but in this thread I’d try to stay on the main theme, so the error about batch converter.

Finally I removed the installation of Kaltura 11.8.0 and I installed the previous versione 11.7.0 and I can confirm you that with this version the problem with the batch converter does not occur.

I hope this will be fixed in the 11.9.0 and I’m available to provide you any further information about that issue.


Hi @jess do you any news about this issue? Reading also the issues on github, the Kaltura team has found that it is an actual problem of version 11.8.0?


Our CI system did not have any issues with batch jobs, if it had, the version would have not been declared stable.
I am now installing a new machine from scratch with 11.8.0 just to make certain and will let you know.

thanks jess. As usual, your support is really appreciated.


I just installed a fresh instance of 11.8.0 and had no issues at all.
I suggest you start by checking whether your batch daemon is running with:
# /etc/init.d/kaltura-batch status
it is probably not.
Then try to start it with:
# /etc/init.d/kaltura-batch start
If after that, it is still down, check /opt/kaltura/log/kaltura_batch.log
for errors.

Then we can further look into it. That said, 11.9.0 is also to be released this Mon. but since no changes were made in this area, it shouldn’t make any difference.

I will re-install in my VM a Kaltura 11.8.0 and I follow your suggestions.

Many thanks Jess! :pray: