Error Loading The Application at login page


Hello, I’m currently stuck when accessing this page. It’s says here that the server-config.json file was not found (404) and I can’t find the server-config.json file either even after I use locate on my vm server. Update I’ve had created a server-config.json in /opt/kaltura and it still 404 not found.

Any solutions for troubleshooting this case? I’m running on Centos7 with apache 2.4.6, PHP 7.4.23 and Kaltura Version 16.14.0

Hello @daivanbl ,

There’s no need to add a server-config.json file.
In order to assist you further, more info is needed.

First of all, Kaltura CE includes multiple web interfaces; which one are you referring to?

Next, to troubleshoot, check the server side logs by running:
# kaltlog in the shell in parallel to making the HTTP request[s] and open the dev tools in the browser and check both the network and console tabs for errors.

Please post the erroneous requests in plain text (never use screen images for that).

Hello @jess

I’m using all of Kaltura Interfaces. But for the one that I was referring is for the kmcng, which access from url/apps/kmcng/v5.17.0/index.html. Note I modifed the index.html by adding full path to call css and js file.

This was yesterday kaltlog
[Tue Sep 28 22:29:20.745569 2021] [authz_core:error] [pid 19496] [client 192.168.56.1:55878] AH01630: client denied by server configuration: /usr/share/pear, referer: http://192.168.56.2/kmcng
[Tue Sep 28 23:39:33.942361 2021] [php7:notice] [pid 19853] [client 192.168.56.1:56550] PHP Notice: Trying to access array offset on value of type bool in /opt/kaltura/app/alpha/apps/kaltura/lib/request/infraRequestUtils.class.php on line 480, referer: http://192.168.56.2/start/index.php
[Tue Sep 28 23:39:34.052422 2021] [php7:notice] [pid 19853] [client 192.168.56.1:56550] Cannot find file on local disk [/opt/kaltura/web//content/generatedUiConf/23/448/ui_conf_23448171__2.config.xml] for file sync [342], referer: http://192.168.56.2/start/index.php

And this is from the Browser
Console
Failed to load resource: the server responded with a status of 404 (Not Found)
main.f057369f9f61fe5a70c2.js:1 Error: failed to load configuration file from server with error Not Found
at XMLHttpRequest.n.onreadystatechange [as __zone_symbol__ON_PROPERTYreadystatechange] (main.f057369f9f61fe5a70c2.js:1)
at XMLHttpRequest.O (polyfills.6a7c00266b7d1c7bccaf.js:1)
at t.invokeTask (polyfills.6a7c00266b7d1c7bccaf.js:1)
at e.runTask (polyfills.6a7c00266b7d1c7bccaf.js:1)
at e.invokeTask [as invoke] (polyfills.6a7c00266b7d1c7bccaf.js:1)
at m (polyfills.6a7c00266b7d1c7bccaf.js:1)
at XMLHttpRequest.b (polyfills.6a7c00266b7d1c7bccaf.js:1)

Network
http://192.168.56.2/server-config.json?v=5.17.0 404

404 Not Found

Not Found

The requested URL /server-config.json was not found on this server.

The Page when I tried access to url/kmcng Got Error 500

Web Console
kmcng:1 GET http://192.168.56.2/kmcng 500 (Internal Server Error)
kmcng:16 GET http://192.168.56.2/sf/sf_default/css/screen.css net::ERR_ABORTED 403 (Forbidden)
kmcng:24 GET http://192.168.56.2/sf/sf_default/images/sfTLogo.png 403 (Forbidden)
kmcng:26 GET http://192.168.56.2/sf/sf_default/images/icons/tools48.png 403 (Forbidden)

Kaltlog

==> /opt/kaltura/log/kaltura_apache_errors.log <==
[Fri Oct 01 03:42:26.221001 2021] [php7:notice] [pid 11005] [client 192.168.56.1:50507] PHP Notice: Trying to access array offset on value of type bool in /opt/kaltura/app/alpha/apps/kaltura/lib/request/infraRequestUtils.class.php on line 480, referer: http://192.168.56.2/start/index.php

2021-10-01 03:42:26 [0.001079] [192.168.56.1] [2071860066] [33] [PS2] [kFileSyncUtils::getLocalContentsByFileSync] INFO: file was not found locally [/opt/kaltura/web//content/generatedUiConf/23/448/ui_conf_23448171__2.config.xml]
2021-10-01 03:42:26 [0.000131] [192.168.56.1] [2071860066] [34] [PS2] [kCoreException->__construct] ERR: kFileSyncException: Cannot find file on local disk [/opt/kaltura/web//content/generatedUiConf/23/448/ui_conf_23448171__2.config.xml] for file sync [342] in /opt/kaltura/app/alpha/apps/kaltura/lib/storage/kFileSyncUtils.class.php:96
Stack trace:
#0 /opt/kaltura/app/alpha/apps/kaltura/lib/storage/kFileSyncUtils.class.php(103): kFileSyncUtils::getLocalContentsByFileSync()

#20 {main}
2021-10-01 03:42:26 [0.000078] [192.168.56.1] [2071860066] [35] [PS2] [sfException->__construct] ERR: {sfException}

Based on the above, you seem to have a half baked DB. I’d advise you to drop it and recreate it. If you encounter errors, post them here, see Kaltura CE Moodle Integration - #2 by jess

Hello @jess
This is the result after running the sanity test script.

PHP Warning: file_get_contents(192.168.56.2/kmc): failed to open stream: No such file or directory in /opt/kaltura/bin/get_kmc_swfs.php on line 11
[Get KMC SWFs] [FAILED, RC: 255] - [.143508780]
[check_start_page] [PASSED, RC: 0] - [.047622865]
[check_testme_page] [PASSED, RC: 0] - [.024247645]
[check_kmc_index_page] [PASSED, RC: 0] - [.285502556]
[check_kmcng_index_page] [FAILED, RC: 1] - [.151805741]
[check_admin_console_index_page] [PASSED, RC: 0] - [.687094810]
[check_studio_index_page] [PASSED, RC: 0] - [.039164810]
[check_clipapp_index_page] [PASSED, RC: 0] - [.986952750]
[Create Partner] [FAILED, RC: 255] - [3.506655239]
Partner creation failed. I will skip all tests that require it.
[Red5 file upload] [SKIPPED as OflaDemo isn’t configured]
see: https://github.com/kaltura/platform-install-packages/blob/master/doc/install-kaltura-redhat-based.md#configure-red5-server

It seems that there’s a failed case so I tried running the drop-db script from the reference that you gave me earlier. Then I tried to run kaltura-db-config.sh script and here’s the result

[root@localrhel sbin]# /opt/kaltura/bin/kaltura-db-config.sh
Usage: /opt/kaltura/bin/kaltura-db-config.sh [upgrade]

By running this script should there any more configuration to be set? Because I dont see any kalutra table inside the database after droping. Or should I re-installed the kaltura?

Hi Daivan,

/opt/kaltura/bin/kaltura-db-config.sh requires arguments (as its usage message states):
Usage: /opt/kaltura/bin/kaltura-db-config.sh <mysql-operational-hostname> <mysql-analytics-hostname> <mysql-super-user> <mysql-super-user-passwd> <mysql-port>

Hello @jess

Here’s the result after running the kaltura-db-config.sh
[root@localrhel sbin]# /opt/kaltura/bin/kaltura-db-config.sh localrhel localrhel root password 80

Checking MySQL version…
ERROR 2013 (HY000): Lost connection to MySQL server at ‘reading initial communication packet’, system error: 0

kaltura-db-config.sh FAILED with: 1 on line 83

Archving logs to /opt/kaltura/log/log_01_10_21_09_57.tar.gz…

And here’s after extracting the file
clear_cache.log
cron.log
kaltura_admin.log
kaltura_apache_access.log
kaltura_apache_errors.log
kaltura_api_v3_analytics.log
kaltura_api_v3.log
kaltura_api_v3_tests.log
kaltura_batch.log
kaltura_monit.log
kaltura_prod.log

Hello @daivanbl ,

I sincerely doubt that your MySQL daemon is running on port 80. The default is 3306. You can check what port it’s running on with:

# netstat -plnt|grep mysql

if netstat isn’t installed, use ss with the same flags.

Got it fixed, I end up re-installing the db just like you said thanks!!@jess

You’re welcome, @daivanbl. Glad we’re good.

Thanks for sharing this.