Dependencies conflict in kaltura-ffmpeg


when trying to install kaltura-ffmpeg on a Amazon AMI EC2 I have this issue:

which block the whole Kaltura installation.
Though I had installed and update manually that libpvx, problem still occurs.



What distribution is are you using?
The issue is that libvpx 1.3.0 or higher is required, whereas you installed 1.2.0.
There is also a conflict as far as httpd-tools is concerned as can be seen in the output you attached.

Thank you for your fast reply.

please ignore the httpd conflicts, it’s depend from stuff I did after trying to find a workaround, not a real issue.

we’re using a Amazon Linux AMI 2015.09 fresh installation and following the “Single-server All-In-One RedHat based Linux distros Installation (including FC, RHEL and CentOS)” guide.

During the installation of Kaltura, I have these issues:

So I used this bash script to manually install ffmpeg. As they say in the comments the repo of libvpx is changed and correctly updated to my script.

After that, the errors are reduced to the screen of the first post.

Any try to update, delete or installation fail and this error persist.
Any suggestion?


My best suggestion would be to use an officially supported system:) we support both RHEL and CentOS, 6 and 7.
There are EC2 images for RHEL7 available, which will work just fine, in fact, we ourselves use them for some of our tests.
Installing ffmpeg manually will not help you, since there is a dependency on the specific version of ffmpeg as supplied by the kaltura-ffmpeg and kaltura-ffmpeg-aux packages.
You can try to add CentOS repos which have correct versions to your /etc/yum.repos.d/ and try to resolve deps that way but I wouldn’t recommend it myself…

Could you please tell us which amazon machines have you tested to use the same?
Thanks in advance.


Please use ami-e2ba9db0

As @jaiswal wrote, you can use ami-e2ba9db0 -

Red Hat Enterprise Linux 7.1 (HVM), SSD Volume Type - ami-12663b7a is also fine. But we do add the CentOS 7 repos to it seeing how it is missing some packages.
If you go with the latter, just add a file called /etc/yum.repos.d/centos.repo:

name=CentOS-7 - Base

#released updates 
name=CentOS-7 - Updates

And proceed as normal. I’d actually recommend going with 7 since it is the latest stable version and has higher versions of packages, including also security fixes, among other things.

Note that if you go with 7, there is a specific section at the guide to look at:

Thank you, your help is precious. We’re going to try the ami-12663b7a

peraphs do you know if there’s a reccomended one for europe region?

Hm… I am sure there is but we use US East so cannot tell you of one:)

Ok very than you! I’m trying with ami-12663b7a, but still stuck in the broken repository error, I’ll let you know

Installation and Red5 both worked!! Thank you!

I’m at point of the tutorial:

Request http://hostname:5080
Click ‘Install a ready-made application’
Mark ‘OFLA Demo’ and click 'Install’

but nothing is showed

ofla demo return a 404, what did I miss?

EDIT: I don’t know what’s happened, but now everything appears correctly.
Again thank you for your big help.


Hi Pico,

Great, glad all is well.

Happy Kalturing,

BTW, would love for you to participate in our survey here:

We will raffle 10 complete Rasperry Pi Kits and a 12 months sponsored account among the participants who completed the survey.