Debian 8.0 Jessie installation missing dependencies

Looks like it was an issue with the vhosts.

# apachectl -t -DDUMP_VHOSTS
VirtualHost configuration:
*:80                   is a NameVirtualHost
         default server (/etc/apache2/sites-enabled/000-default.conf:1)
         port 80 namevhost (/etc/apache2/sites-enabled/000-default.conf:1)
         port 80 namevhost (/etc/apache2/sites-enabled/zzzkaltura.conf:1)
                 alias kcetest

The default server was using the same name. I changed the default server name and now the calls are working.

One last thing. I can’t seem to log in with the admin user I created during the install. Is there a way to set up that user manually, or do I need to reconfig a package?

Please follow:

To reset the passwd. You can also just hit the forgot passwd href and it will send you an email with a link to reset.

Hmm, looks like my user does not exists at all:

mysql> use kaltura
mysql> select * from user_login_data;
Empty set (0.00 sec)

Similar exception in the logs

#7 {main}
2015-05-01 09:33:39 [0.000392] [] [2087144562] [API] [KalturaFrontController->getExceptionObject] ERR: exception 'KalturaAPIException' with message 'User was not found' in /opt/kaltura/app/api_v3/lib/KalturaBaseUserService.php:187
Stack trace:
#0 /opt/kaltura/app/api_v3/services/UserService.php(360): KalturaBaseUserService->loginImpl(NULL, 'jramer@emaildom...', 'password', -2, 86400, 'disableentitlem...')

So I could probably add a line to the DB, but I am wondering if this indicates something wasn’t set up properly. Maybe I should drop the kaltura db and start all reconfigures from scratch…

I suggest you drop the DB with and then reconfigure kaltura-db.

Please make sure it completes correctly. Other packages do not need reconfiguration. Before you commence, just make sure the call to http://$SERVICE_URL/api_v3 returns with HTTP 200.

That did the trick. Clearly the vhost settings from earlier were causing an issue with the API calls made during DB setup. Login seems to be working now. Thanks again Jess!