"Could not retreive partner.admin_secret" and "Must have Flash Installed"

Hello there! I have created this new topic because I was only limited to 3 replies on the last thread. Sorry about any confusion.

Everything has gone quite well and I am nearly there. I have redone the installation more than once and get the same error each time. I am using a VPS from GoDaddy. CentOS 6.5. PHP is 5.3 and MySQL is v5.1.



I ran the drop db command and then did kaltura-config-all.

Here is the output:

Configuration of Kaltura Server 9.19.5 finished successfully!
Running FrontEnd config…

base-config completed successfully, if you ever want to re-configure you r system (e.g. change DB hostname) run the following script:

rm /opt/kaltura/app/base-config.lock
Is your Apache working with SSL?[Y/n]
Please input path to your SSL certificatePlease input path to your SSL keyPlease input path to your SSL chain file or leave empty in case you have none:

WARNING: self signed cerificate detected. Will set settings.clientConfig.verifySSL=0 in

Which port will this Vhost listen on? [443]

Please select one of the following options [0]:
0. All web interfaces

  1. Kaltura Management Console [KMC], Hosted Apps, HTML5 lib and ClipApp
  2. KAC - Kaltura Admin Console
    Enabling Apache config - apps.conf
    Enabling Apache config - var.conf
    Enabling Apache config - admin.conf

Kaltura install answer file written to /tmp/kaltura_11_11_17_02.ans - Please save it!
This answers file can be used to silently-install re-install this machine or deploy oth

Stopping httpd: [ OK ]
Starting httpd: [ OK ]
Shutting down monit: [ OK ]
Starting monit: Starting monit daemon with http interface at [*:2812]
[ OK ]
Running Sphinx config…

base-config completed successfully, if you ever want to re-configure your system (e.g.

rm /opt/kaltura/app/base-config.lock
Starting monit: Starting monit daemon with http interface at [*:2812]
[ OK ]
Running Batch config…

base-config completed successfully, if you ever want to re-configure your system (e.g.

rm /opt/kaltura/app/base-config.lock
ERROR: could not retreive partner.admin_secret for id -1. It probably means you did notease do.
ERROR: /opt/kaltura/bin/kaltura-batch-config.sh failed:( You can re-run it when the iss
Running DWH config…

base-config completed successfully, if you ever want to re-configure your system (e.g.

rm /opt/kaltura/app/base-config.lock
Deploying analytics warehouse DB, please be patient as this may take a while…
Output is logged to /opt/kaltura/dwh/logs/dwh_setup.log.

sending incremental file list

sent 133 bytes received 25 bytes 316.00 bytes/sec
total size is 2646419 speedup is 16749.49
sending incremental file list

sent 143 bytes received 25 bytes 336.00 bytes/sec
total size is 90670 speedup is 539.70
sending incremental file list

sent 141 bytes received 25 bytes 332.00 bytes/sec
total size is 7308893 speedup is 44029.48
sending incremental file list

sent 131 bytes received 25 bytes 312.00 bytes/sec
total size is 5783119 speedup is 37071.28
sending incremental file list

sent 126 bytes received 25 bytes 302.00 bytes/sec
total size is 3687964 speedup is 24423.60
sending incremental file list

sent 80 bytes received 12 bytes 184.00 bytes/sec
total size is 34770 speedup is 377.93
current version 5999
DWH configured.


Setup completed successfully!


Is the service URL you used to install resolvable from the outside?

Hi Jess,

The domain I am using with the server is on a redirect. However, when I go to the server IP (, the Apache 2 Test Page comes up. This is the same for port 80. Should I reassign kmc to a different port? Or assign a page in /var/www/html?

I’m afraid I really have no formal training with servers and am following all the instructions I can find.

Thank you for your patience and help!



If it goes to the default Apache page then the VHost settings have an issue, or perhaps you configured Kaltura over SSL?
what is the output for:

# apachectl -t -DDUMP_VHOSTS


I originally used SSL but since it was self-hosted I have removed and re-installed Kaltura.

I get the following with the command you sent:

VirtualHost configuration:
wildcard NameVirtualHosts and default servers:
default:443 ip-192-169-201-75.secureserver.net (/etc/httpd/conf.d/ssl.conf:74)
*:80 ip-192-169-201-75.secureserver.net (/etc/httpd/conf.d/zzzkaltura.conf:1)
Syntax OK
root@ip-192-169-201-75 [~]#

Now when I go to the IP, it’s the Kaltura Get Started Page. Same for IP:80. The same error about admin_secret id-1 still appears in the kaltura-config-all.sh setup.



Seems to me your DB was not correctly built.
I suggest you kaltura-drop-db.sh and then re-rerun kaltura-db-config.sh.
Please make sure it finishes correctly and then re-run kaltura-batch-config.sh.

If something fails, paste the output here.


I get the following message:

Checking MySQL version…
Ver 5.1.73 found compatible

CREATE USER kaltura;
CREATE DATABASE kaltura_sphinx_log;
CREATE DATABASE kalturadw_ds;
CREATE DATABASE kalturadw_bisources;
Checking connectivity to needed daemons…
Connectivity test passed:)
ERROR: Couldn’t make an API request to http:// ip-192-169-201-75.secureserver.net:80/api_v3/index.php?service=system&action=ping
Please check your setup and then run /opt/kaltura/bin/kaltura-db-config.sh again.

Thank you,


This means the following failed:
$ curl -v -I http://ip-192-169-201-75.secureserver.net:80/api_v3/index.php?service=system&action=ping
What is the HTTP error this gives?

ip-192-169-201-75.secureserver.net MUST be accessible from both inside the machine and your client [browser]

Once you ensure this curl command returns 200, drop the DB again and redo the step.

Hi, sorry for the long delay. I have resolved this and it now returns HTTP/1.1 200 OK.

I can access the log in page with my KMC but the credentials are invalid because of the partner admin secret id=-1 error I receive during the kaltura-config-all.sh and kaltura-batch-config.sh commands. I have dropped the dbs and re-created them which goes okay. It’s puzzling!

Thank you,

Here is the Kaltura_batch log:
root@e-reelz [/opt/kaltura/log]# vi kaltura_batch.log
X-Powered-By: PHP/5.3.29^M
Content-type: text/html^M

Fatal error: Uncaught exception ‘Zend_Config_Exception’ with message ‘Section ‘e-reelz.co.uk’ cannot be found in /opt/kaltura/app/cache//batch/config.ini’ in /opt/kaltura/app/vendor/ZendFramework/library/Zend/Config/Ini.php:150
Stack trace:
#0 /opt/kaltura/app/batch/scheduler/KSchedulerConfig.class.php(59): Zend_Config_Ini->__construct(’/opt/kaltura/ap…’, ‘e-reelz.co.uk’, true)
#1 /opt/kaltura/app/batch/scheduler/KSchedulerConfig.class.php(42): KSchedulerConfig->load()
#2 /opt/kaltura/app/batch/scheduler/KGenericScheduler.class.php(81): KSchedulerConfig->__construct(’/opt/kaltura/ap…’)
#3 /opt/kaltura/app/batch/scheduler/KGenericScheduler.class.php(63): KGenericScheduler->loadConfig(’/opt/kaltura/ap…’)
#4 /opt/kaltura/app/batch/KGenericBatchMgr.class.php(37): KGenericScheduler->__construct(’/usr/bin/php’, ‘/opt/kaltura/ap…’)
#5 {main}
thrown in /opt/kaltura/app/vendor/ZendFramework/library/Zend/Config/Ini.php on line 150


Now that you resolved the issue, you need to repopulate your DB.
# kaltura-drop-db.sh
then re-run the config script.


That helped resolve the admin partner issue but the configuration is saying ERROR: we failed on something else…

Populating DB with data… please wait…
Output for /opt/kaltura/app/deployment/base/scripts/installPlugins.php being logged into /opt/kaltura/log/installPlugins.log

            Archving logs to /opt/kaltura/log/log_14_12_14_10_23.tar.gz...

ERROR: we failed on something else…

I used ctrl-shift-i with Chrome on the KMC login page and it says: Failed to load resource: net::ERR_CACHE_MISS

And with the kaltura-sanity.sh command, batch-config fails.

Thank you,


Take a look at /opt/kaltura/log/installPlugins.log to see what the problem is.
Then drop the DB and re-run.
Until the installation complete successfully, there is no point in trying to login to KMC.

I am having ERR_CACHE_MISS problem in my Pc.


More info is needed. To start with:
Where do you see this error? I am assuming in the “console” tab of your browser’s dev tools? Also, what action are you performing when you get this error?


after 3 days now I’ve successfully found the solution, its my chrome who’s making the problem
here’s the fix