Centos7 update dependency error

Today I tried to update some CentOS7 packages via

yum update

as usual. Normally that worked very well but today I get this message:

—> Package util-linux.x86_64 0:2.23.2-26.el7_2.2 will be updated
—> Package util-linux.x86_64 0:2.23.2-26.el7_2.3 will be an update
–> Processing Dependency: /usr/sbin/ldconfig for package: xvidcore-1.3.2-16.x86_64
–> Processing Dependency: /usr/sbin/ldconfig for package: xvidcore-1.3.2-16.x86_64
–> Finished Dependency Resolution
Error: Package: xvidcore-1.3.2-16.x86_64 (@Kaltura)
Requires: /usr/sbin/ldconfig
Removing: glibc-2.17-106.el7_2.6.i686 (@updates)
Not found
Updated By: glibc-2.17-106.el7_2.8.i686 (updates)
Not found
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Any hint what to do or wait for some kaltura update?

Keen on updating to 11.20 I just tried those lines:

rpm -Uvh --nodeps $(repoquery --location glibc)
yum update
yum reinstall xvidcore
yum update

And that worked for me.
Short meaning: I manually updated the glibc from 2.6 to 2.8 without looking for a breaking dependency which would have been the xvidcore package. After that I updated the whole bunch and to be sure reinstalled the xvidcore again, hoping it will find the new glibc if anything changed.

So far it seems to work.

Hi @kaikretschmann_1,

This is pretty much the same issue as described here:

What you did should work fine.
If you have additional questions or issues, do let me know.